summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerhard Bräunlich <wippbox@gmx.net>2016-09-09 16:55:38 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-18 15:29:02 +0200
commitea24ab2c6498296cbc5746f38e7221fa5a5d6e8c (patch)
tree334df5910abfe27c13b2b2f497b4efc2b0974ce2 /sci-mathematics
parentmedia-plugins/calf: fix cpp14 compilation errors, bug #594116 (diff)
downloadgentoo-ea24ab2c6498296cbc5746f38e7221fa5a5d6e8c.tar.gz
gentoo-ea24ab2c6498296cbc5746f38e7221fa5a5d6e8c.tar.bz2
gentoo-ea24ab2c6498296cbc5746f38e7221fa5a5d6e8c.zip
sci-mathematics/pymc: version bump to 2.3.6 and porting to EAPI 6
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/2283 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/pymc/Manifest1
-rw-r--r--sci-mathematics/pymc/files/pymc-2.3.6-remove-hardcoded-blas.patch11
-rw-r--r--sci-mathematics/pymc/pymc-2.3.6.ebuild54
3 files changed, 66 insertions, 0 deletions
diff --git a/sci-mathematics/pymc/Manifest b/sci-mathematics/pymc/Manifest
index 401575ac5a4b..3ff2ed606dca 100644
--- a/sci-mathematics/pymc/Manifest
+++ b/sci-mathematics/pymc/Manifest
@@ -1 +1,2 @@
DIST pymc-2.2.tar.gz 13137644 SHA256 f618ebb9f075219b1aad5c06156f46fcd5ac543f391de4fa3752f311e9965278 SHA512 1fc44ec68f4a5b773d0705489810774e80c72c52dcfa601cf564737490fbf9e2f12696fb8bf6c706e0d157c3568f68b0b95f9a9846716a88c5a0f5c0ca706a96 WHIRLPOOL ec907b135e5d3bb2cbfb3158afbd8cf054abcdd81c6a11424a214646a471a08dc86e80423f299c5a152b8bd5356653399f5252f6ec06ec0ee87ab44f07a949ca
+DIST pymc-2.3.6.zip 402827 SHA256 70b00a9d722d9bba95d975f0a0836e41d8792b8d6fe0dd21b4af209747da3dc5 SHA512 4b5e0663ca296efd8d242a0b6362a12d475cdabf661a430de5455e60999acf8a4a30d053303c2f79e8aec3e5e7d120f56cb341e283aa87f31c224e4e57300d13 WHIRLPOOL 4a0774e0362baef7c6390ec499ba6f605766c614974f04bd9c04e78916b91e0e7f4d35d39e8ba002c654ad15c7158b8b670e6c7010eb1fd8513bfd43e0fe61db
diff --git a/sci-mathematics/pymc/files/pymc-2.3.6-remove-hardcoded-blas.patch b/sci-mathematics/pymc/files/pymc-2.3.6-remove-hardcoded-blas.patch
new file mode 100644
index 000000000000..93ce86f5c717
--- /dev/null
+++ b/sci-mathematics/pymc/files/pymc-2.3.6-remove-hardcoded-blas.patch
@@ -0,0 +1,11 @@
+--- a/setup.py
++++ b/setup.py
+@@ -80,7 +80,7 @@
+
+ # Compile covariance functions
+ config.add_extension(name='gp.cov_funs.isotropic_cov_funs',\
+-sources=['pymc/gp/cov_funs/isotropic_cov_funs.f','blas/BLAS/dscal.f'],\
++sources=['pymc/gp/cov_funs/isotropic_cov_funs.f'],\
+ extra_info=lapack_info)
+
+ config.add_extension(name='gp.cov_funs.distances',sources=['pymc/gp/cov_funs/distances.f'], extra_info=lapack_info)
diff --git a/sci-mathematics/pymc/pymc-2.3.6.ebuild b/sci-mathematics/pymc/pymc-2.3.6.ebuild
new file mode 100644
index 000000000000..3d5e8199ddb4
--- /dev/null
+++ b/sci-mathematics/pymc/pymc-2.3.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 flag-o-matic fortran-2 toolchain-funcs
+
+DESCRIPTION="Markov Chain Monte Carlo sampling toolkit"
+HOMEPAGE="https://github.com/${PN}-devs/${PN} https://pypi.python.org/pypi/${PN}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+SLOT=0
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE=AFL-3.0
+IUSE="test"
+
+RDEPEND=">=dev-python/numpy-1.6[${PYTHON_USEDEP},lapack]
+ >=dev-python/matplotlib-1.0[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=( "${FILESDIR}/${PN}-2.3.6-remove-hardcoded-blas.patch" )
+
+# tests freeze at some point
+#RESTRICT="test"
+
+python_prepare_all() {
+ # forcibly remove bundled libs, just to be sure...
+ rm -r blas || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ append-fflags -fPIC
+ append-ldflags -shared
+
+ [[ $(tc-getFC) == *gfortran* ]] && mydistutilsargs=( config_fc --fcompiler=gnu95 )
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}" || die
+ # Use agg backend instead of gtk
+ echo 'backend : agg' > matplotlibrc || die
+
+ ${EPYTHON} -c "import pymc; pymc.test()" || die "Tests failed on ${EPYTHON}"
+}