summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-misc/mendeleydesktop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-misc/mendeleydesktop')
-rw-r--r--sci-misc/mendeleydesktop/Manifest2
-rw-r--r--sci-misc/mendeleydesktop/mendeleydesktop-1.14.ebuild122
-rw-r--r--sci-misc/mendeleydesktop/metadata.xml26
3 files changed, 150 insertions, 0 deletions
diff --git a/sci-misc/mendeleydesktop/Manifest b/sci-misc/mendeleydesktop/Manifest
new file mode 100644
index 000000000000..7c21798ffafb
--- /dev/null
+++ b/sci-misc/mendeleydesktop/Manifest
@@ -0,0 +1,2 @@
+DIST mendeleydesktop-1.14-linux-i486.tar.bz2 33111869 SHA256 42c789b265545ccd8056668111cc6e7a09850491f2719e30170936f4e0940d6c SHA512 57e4f2e2af9644e6170755c008dea715cc206880425dd5fd9bb18052cdec769b1cab5e2226725e7614f29cce8e42039f2e394db81495de371a4ffa11ea967d0f WHIRLPOOL 5e0772618348715a48ab43563c55f96d8bba5a99db07d29b4dca86e711e4ce2a0dcabd90270f9384879a70c78a55f58b70c18c77658919e292f77d107f2050be
+DIST mendeleydesktop-1.14-linux-x86_64.tar.bz2 32843455 SHA256 bfab457fe2a896539059bc301fc1daf15b0b03180b21ea083a0929ffbc699d70 SHA512 690477edd15d9f48d7bb5b87fe42b07cc187b9ab9c307836980af00a0e409bbbf5ce5980b9bdc039a466c4389ef17ed37c9fd3e8fb5deb535bf9e5d2f4c8ac85 WHIRLPOOL defb4e19889c17074447d11a2e75b6a96ead68140bea290629ed095ebcc5e966bf5c5dd1204908c731f3532ea6ba97794cc435a75365493e014aa36d0cc6e4ff
diff --git a/sci-misc/mendeleydesktop/mendeleydesktop-1.14.ebuild b/sci-misc/mendeleydesktop/mendeleydesktop-1.14.ebuild
new file mode 100644
index 000000000000..34b00514635e
--- /dev/null
+++ b/sci-misc/mendeleydesktop/mendeleydesktop-1.14.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit eutils fdo-mime multilib python-single-r1
+
+MY_P_AMD64="${P}-linux-x86_64"
+MY_P_X86="${P}-linux-i486"
+
+DESCRIPTION="Research management tool for desktop and web"
+HOMEPAGE="http://www.mendeley.com/"
+SRC_URI="
+ amd64? ( ${MY_P_AMD64}.tar.bz2 )
+ x86? ( ${MY_P_X86}.tar.bz2 )
+ amd64-linux? ( ${MY_P_AMD64}.tar.bz2 )
+ x86-linux? ( ${MY_P_X86}.tar.bz2 )"
+
+LICENSE="Mendeley-terms"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="fetch"
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtsvg:4
+ dev-qt/qtwebkit:4
+ dev-qt/qtxmlpatterns:4
+ x11-libs/libX11
+ "
+
+QA_PREBUILT="/opt/mendeleydesktop/.*"
+
+pkg_nofetch() {
+ elog "Please download ${A} from:"
+ elog "http://www.mendeley.com/download-mendeley-desktop/"
+ elog "and move it to ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${WORKDIR}" || die
+
+ if use amd64 || use amd64-linux ; then
+ mv -f "${MY_P_AMD64}" "${P}" || die
+ else
+ mv -f "${MY_P_X86}" "${P}" || die
+ fi
+}
+
+src_prepare() {
+ # remove bundled Qt libraries
+ rm -r lib/mendeleydesktop/plugins \
+ || die "failed to remove plugin directory"
+ rm -r lib/qt || die "failed to remove qt libraries"
+
+ # force use of system Qt libraries
+ sed -i "s:sys\.argv\.count(\"--force-system-qt\") > 0:True:" \
+ bin/mendeleydesktop || die "failed to patch startup script"
+
+ # fix library paths
+ sed -i \
+ -e "s:lib/mendeleydesktop:$(get_libdir)/mendeleydesktop:g" \
+ -e "s:MENDELEY_BASE_PATH + \"/lib/\":MENDELEY_BASE_PATH + \"/$(get_libdir)/\":g" \
+ bin/mendeleydesktop || die "failed to patch library path"
+}
+
+src_install() {
+ # install menu
+ domenu share/applications/${PN}.desktop
+
+ # install application icons
+ insinto /usr/share/icons
+ doins -r share/icons/hicolor
+
+ # install default icon
+ insinto /usr/share/pixmaps
+ doins share/icons/hicolor/48x48/apps/${PN}.png
+
+ # install documentation, but no license file
+ dodoc share/doc/${PN}/Readme.txt
+
+ # install binary
+ python_fix_shebang bin/${PN}
+ into /opt/${PN}
+ dobin bin/*
+
+ # install libraries
+ dolib.so lib/lib*.so*
+
+ # install programs
+ exeinto /opt/mendeleydesktop/$(get_libdir)/mendeleydesktop/libexec
+ doexe lib/mendeleydesktop/libexec/*
+
+ # install shared files
+ insinto /opt/${PN}/share
+ doins -r share/mendeleydesktop
+
+ # install launch script
+ into /opt
+ make_wrapper ${PN} "/opt/${PN}/bin/${PN} --unix-distro-build"
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/sci-misc/mendeleydesktop/metadata.xml b/sci-misc/mendeleydesktop/metadata.xml
new file mode 100644
index 000000000000..b896b3ebe0a0
--- /dev/null
+++ b/sci-misc/mendeleydesktop/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>miknix@gentoo.org</email>
+ <name>Angelo Arrifano</name>
+ </maintainer>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <maintainer>
+ <email>marbre@linux.sungazer.de</email>
+ <name>Marius Brehler</name>
+ </maintainer>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ <description>proxy for Marius</description>
+ </maintainer>
+ <longdescription>
+Mendeley(TM) is a free reference manager and academic social network that can
+help you organize your research, collaborate with others online, and discover
+the latest research.
+</longdescription>
+</pkgmetadata>