summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-misc/ncview
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-misc/ncview')
-rw-r--r--sci-misc/ncview/Manifest2
-rw-r--r--sci-misc/ncview/metadata.xml12
-rw-r--r--sci-misc/ncview/ncview-2.1.1.ebuild32
-rw-r--r--sci-misc/ncview/ncview-2.1.2.ebuild33
4 files changed, 79 insertions, 0 deletions
diff --git a/sci-misc/ncview/Manifest b/sci-misc/ncview/Manifest
new file mode 100644
index 000000000000..1452600da0e2
--- /dev/null
+++ b/sci-misc/ncview/Manifest
@@ -0,0 +1,2 @@
+DIST ncview-2.1.1.tar.gz 1232134 SHA256 8aaf98fad15790313739520b88e17748617be504f0a2b0322a62144e390db1dd SHA512 3cb8156670b2f6e6028df028641b3d6f0909fe0a9fd255f3189c5937c9fd2bd7fb2ac0c2be17aa74c6a8e7b7a67e6e1ac6e5691fe2e01091ce9b0b221890e992 WHIRLPOOL 84fdcd04fce130b4bff216d750b3d369bbdec55300402361c4a6041ebe223382a9633a288ae81400a39be3dd5451e56cddc5640e4f78e3ef928959bb9824a9e0
+DIST ncview-2.1.2.tar.gz 1269929 SHA256 099165e85d5aa15c3091e856b1003de768db75f5824a364cbe6bab6698244f4e SHA512 8146be3b20870a3dbbf44e8e1c51a18f36bcc60827a969f15606ba7ae068f1e4598fc2004612f84e17cffec1960f6683ee56f15b91e46eb82db173f7b7baa1dc WHIRLPOOL cd75101e5bcb2d15ddd0088cc726bc0efcf2182b1deb58f894cc98aad2ed2b05c105fa683cb2b552da124f9089c2b8bbfc179a75916959fc0a05b9977e7464ca
diff --git a/sci-misc/ncview/metadata.xml b/sci-misc/ncview/metadata.xml
new file mode 100644
index 000000000000..a4c406ecfd48
--- /dev/null
+++ b/sci-misc/ncview/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ Ncview is a visual browser for netCDF format files. Typically you
+ would use ncview to get a quick push-button look at your netCDF
+ files. You can view movies of the data, view along various
+ dimensions, take a look at the actual data values, change color
+ maps, invert the data, etc.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-misc/ncview/ncview-2.1.1.ebuild b/sci-misc/ncview/ncview-2.1.1.ebuild
new file mode 100644
index 000000000000..56deb16554ad
--- /dev/null
+++ b/sci-misc/ncview/ncview-2.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="X-based viewer for netCDF files"
+HOMEPAGE="http://meteora.ucsd.edu/~pierce/ncview_home_page.html"
+SRC_URI="ftp://cirrus.ucsd.edu/pub/ncview/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="media-libs/libpng
+ >=sci-libs/netcdf-4.1[hdf5]
+ x11-libs/libXaw
+ sci-libs/udunits"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ default
+ doman data/${PN}.1
+ insinto /usr/share/X11/app-defaults
+ newins Ncview-appdefaults Ncview
+ insinto /usr/share/${PN}
+ doins *.ncmap
+ make_desktop_entry ${PN}
+}
diff --git a/sci-misc/ncview/ncview-2.1.2.ebuild b/sci-misc/ncview/ncview-2.1.2.ebuild
new file mode 100644
index 000000000000..be78dfe0e9af
--- /dev/null
+++ b/sci-misc/ncview/ncview-2.1.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="X-based viewer for netCDF files"
+HOMEPAGE="http://meteora.ucsd.edu/~pierce/ncview_home_page.html"
+SRC_URI="ftp://cirrus.ucsd.edu/pub/ncview/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ media-libs/libpng
+ >=sci-libs/netcdf-4.1[hdf5]
+ x11-libs/libXaw
+ sci-libs/udunits"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ default
+ doman data/${PN}.1
+ insinto /usr/share/X11/app-defaults
+ newins Ncview-appdefaults Ncview
+ insinto /usr/share/${PN}
+ doins *.ncmap
+ make_desktop_entry ${PN}
+}