summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-misc/vitables
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-misc/vitables')
-rw-r--r--sci-misc/vitables/Manifest1
-rw-r--r--sci-misc/vitables/files/vitables-2.1-no-docs.patch19
-rw-r--r--sci-misc/vitables/metadata.xml11
-rw-r--r--sci-misc/vitables/vitables-2.1.ebuild56
4 files changed, 87 insertions, 0 deletions
diff --git a/sci-misc/vitables/Manifest b/sci-misc/vitables/Manifest
new file mode 100644
index 000000000000..ef109face042
--- /dev/null
+++ b/sci-misc/vitables/Manifest
@@ -0,0 +1 @@
+DIST ViTables-2.1.tar.gz 3111661 SHA256 f0413fa725617fbb3f0be03cb1f41b5b841c6946098a629f3fcb8a99fb9be14a SHA512 9ca48fbc8aa33dd3e1e02e2cf2055082831a95f5c24a2ab3bb294d7b09a3f09e62e500b0d69f8843a93af0db6dfc25873a57604f3fd433c0168eb335a1816bc8 WHIRLPOOL d526744105cea3ef7812db52f5e1a2ef74ca43431de167355afe0c6670a2752d3f4f5613f72f1f11e043cd6de0d4007086b4d548e78f7a3cbeaf4a5c6695babc
diff --git a/sci-misc/vitables/files/vitables-2.1-no-docs.patch b/sci-misc/vitables/files/vitables-2.1-no-docs.patch
new file mode 100644
index 000000000000..307fb65b043c
--- /dev/null
+++ b/sci-misc/vitables/files/vitables-2.1-no-docs.patch
@@ -0,0 +1,19 @@
+--- setup.py.orig 2011-02-15 11:05:17.000000000 -0800
++++ setup.py 2012-08-04 12:00:40.704723726 -0700
+@@ -34,13 +34,14 @@
+ from distutils.dir_util import copy_tree
+ from distutils.file_util import copy_file
+
++sphinx_found = True
+ try:
+ from sphinx.setup_command import BuildDoc
+ except ImportError:
+- pass
++ sphinx_found = False
++
+
+
+-sphinx_found = True
+
+
+
diff --git a/sci-misc/vitables/metadata.xml b/sci-misc/vitables/metadata.xml
new file mode 100644
index 000000000000..12cad61721d7
--- /dev/null
+++ b/sci-misc/vitables/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription>
+ ViTables is a component of the PyTables family. It is a GUI for
+ browsing and editing files in both PyTables and HDF5 formats. It is
+ developed using Python and PyQt (the Python bindings to the Qt), so
+ it can run on any platform that supports these components.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-misc/vitables/vitables-2.1.ebuild b/sci-misc/vitables/vitables-2.1.ebuild
new file mode 100644
index 000000000000..244125536a6e
--- /dev/null
+++ b/sci-misc/vitables/vitables-2.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+MY_PN=ViTables
+MY_P=${MY_PN}-${PV}
+
+inherit distutils eutils
+
+DESCRIPTION="A graphical tool for browsing and editing files in both PyTables and HDF5 formats"
+HOMEPAGE="http://vitables.org/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="
+ dev-python/pytables
+ dev-python/PyQt4[X]" # FIXME: check if any other useflags are needed
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-docs.patch
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ # fixme: multiple python (anyone cares?)
+ python setup.py build_sphinx || die
+ fi
+}
+
+src_install() {
+ dodir /usr/share/icons/hicolor/scalable/apps
+ dodir /usr/share/applications
+ XDG_DATA_DIRS="${ED}/usr/share" distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+ fi
+ use doc && dohtml -r build/sphinx/html/* && \
+ dodoc build/sphinx/latex/*.pdf
+}