summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-02-19 19:17:21 +0100
committerDavid Seifert <soap@gentoo.org>2018-02-19 20:40:50 +0100
commit52c6f961172a73e219b4b378279103713c3ce445 (patch)
treeaff81a54b72c42e80c985fb160f43dd1cec98144 /sci-misc
parentsci-libs/xdmf2: Always build in C++14 mode (diff)
downloadgentoo-52c6f961172a73e219b4b378279103713c3ce445.tar.gz
gentoo-52c6f961172a73e219b4b378279103713c3ce445.tar.bz2
gentoo-52c6f961172a73e219b4b378279103713c3ce445.zip
sci-misc/lttoolbox: Always build in C++14 mode
Closes: https://bugs.gentoo.org/619446 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/lttoolbox/lttoolbox-3.3.3.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sci-misc/lttoolbox/lttoolbox-3.3.3.ebuild b/sci-misc/lttoolbox/lttoolbox-3.3.3.ebuild
index ad7dca2d16a2..28266cdb4f73 100644
--- a/sci-misc/lttoolbox/lttoolbox-3.3.3.ebuild
+++ b/sci-misc/lttoolbox/lttoolbox-3.3.3.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools
+
+inherit autotools flag-o-matic
DESCRIPTION="Toolbox for lexical processing, morphological analysis and generation of words"
HOMEPAGE="https://www.apertium.org"
@@ -23,5 +24,8 @@ src_prepare() {
}
src_configure() {
+ # bug 619446
+ append-cxxflags -std=c++14
+
econf $(use_enable static-libs static)
}