summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@prydeworx.com>2021-04-24 14:51:30 +0200
committerDavid Seifert <soap@gentoo.org>2021-04-24 14:51:30 +0200
commit5ae54d1e747b699aef71cd549555968db56a11e2 (patch)
tree47049e561b2b3711e4acf41ba0e5f82d08f2631d /sci-misc
parentsys-devel/kgcc64: bump up to 10.3.0 (diff)
downloadgentoo-5ae54d1e747b699aef71cd549555968db56a11e2.tar.gz
gentoo-5ae54d1e747b699aef71cd549555968db56a11e2.tar.bz2
gentoo-5ae54d1e747b699aef71cd549555968db56a11e2.zip
sci-misc/boinc: Fix installation with imagemagick[-xml]
If imagemagick is installed with USE="-xml" when installing boinc with USE="X", the process off creating png icons using `convert` fails with the following messages: ======== convert: Incorrect value for "RichTIFFIPTC"; tag ignored. `TIFFFetchNormalTag' @ warning/tiff.c/TIFFWarnings/1046. convert: delegate library support not built-in '/data/portage/portage/sci-misc/boinc-7.14.2/distdir/boinc.tif' (XML) @ error/profile.c/ValidateXMPProfile/1927. convert: Incorrect value for "RichTIFFIPTC"; tag ignored. `TIFFFetchNormalTag' @ warning/tiff.c/TIFFWarnings/1046. ======== Actually these are just warnings from libtiff, and the conversion succeeds. There is no problem with the resulting PNGs. This commit switches the check'n'fail from the `convert` command to the `newicon` command, so we only fail if the target PNG really could not be created. Also add some minor fixes to the ebuild. Closes: https://bugs.gentoo.org/766093 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Sven Eden <sven.eden@prydeworx.com> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/boinc/boinc-7.16.14.ebuild15
-rw-r--r--sci-misc/boinc/boinc-9999.ebuild17
2 files changed, 20 insertions, 12 deletions
diff --git a/sci-misc/boinc/boinc-7.16.14.ebuild b/sci-misc/boinc/boinc-7.16.14.ebuild
index cf696e8c6bc7..3f403c0a77fc 100644
--- a/sci-misc/boinc/boinc-7.16.14.ebuild
+++ b/sci-misc/boinc/boinc-7.16.14.ebuild
@@ -6,7 +6,7 @@ EAPI=7
MY_PV=$(ver_cut 1-2)
WX_GTK_VER=3.0-gtk3
-inherit autotools desktop linux-info systemd wxwidgets xdg-utils
+inherit autotools desktop flag-o-matic linux-info systemd wxwidgets xdg-utils
DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
HOMEPAGE="https://boinc.ssl.berkeley.edu/"
@@ -107,8 +107,6 @@ src_prepare() {
eautoreconf
- use X && setup-wxwidgets
-
# bug #732024
if test "x$(get_libdir)" = "xlib64"; then
sed -i -e 's,/lib\([ /;:"]\),/lib64\1,g' configure || die
@@ -116,7 +114,10 @@ src_prepare() {
}
src_configure() {
- LDFLAGS="-L${EPREFIX}/usr/$(get_libdir) -L${EPREFIX}/$(get_libdir) ${LDFLAGS}" \
+ use X && setup-wxwidgets
+
+ append-libs -L"${ESYSROOT}"/usr/$(get_libdir) -L"${ESYSROOT}"/$(get_libdir)
+
econf --disable-server \
--enable-client \
--enable-dynamic-client-linkage \
@@ -137,7 +138,11 @@ src_install() {
# Create new icons. bug 593362
local s SIZES=(16 22 24 32 36 48 64 72 96 128 192 256)
for s in "${SIZES[@]}"; do
- convert "${DISTDIR}"/${PN}.tif -resize ${s}x${s} "${WORKDIR}"/boinc_${s}.png || die
+ # The convert command is not checked, because it will issue warnings and exit with
+ # an error code if imagemagick is used and was merged with USE="-xml", although the
+ # conversion has worked. See #766093
+ # Instead, newicon will fail if the conversion did not produce the icon.
+ convert "${DISTDIR}"/${PN}.tif -resize ${s}x${s} "${WORKDIR}"/boinc_${s}.png
newicon -s $s "${WORKDIR}"/boinc_${s}.png boinc.png
done
make_desktop_entry boincmgr "${PN}" "${PN}" "Math;Science" "Path=/var/lib/${PN}"
diff --git a/sci-misc/boinc/boinc-9999.ebuild b/sci-misc/boinc/boinc-9999.ebuild
index cf696e8c6bc7..213bded49211 100644
--- a/sci-misc/boinc/boinc-9999.ebuild
+++ b/sci-misc/boinc/boinc-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=7
MY_PV=$(ver_cut 1-2)
WX_GTK_VER=3.0-gtk3
-inherit autotools desktop linux-info systemd wxwidgets xdg-utils
+inherit autotools desktop flag-o-matic linux-info systemd wxwidgets xdg-utils
DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
HOMEPAGE="https://boinc.ssl.berkeley.edu/"
@@ -67,8 +67,6 @@ RDEPEND="${COMMON_DEPEND}
PATCHES=(
# >=x11-libs/wxGTK-3.0.2.0-r3 has webview removed, bug 587462
"${FILESDIR}"/${PN}-${MY_PV}-fix_webview.patch
- # bug #732024
- "${FILESDIR}"/${PN}-${MY_PV}-remove-usr_lib.patch
)
pkg_setup() {
@@ -107,8 +105,6 @@ src_prepare() {
eautoreconf
- use X && setup-wxwidgets
-
# bug #732024
if test "x$(get_libdir)" = "xlib64"; then
sed -i -e 's,/lib\([ /;:"]\),/lib64\1,g' configure || die
@@ -116,7 +112,10 @@ src_prepare() {
}
src_configure() {
- LDFLAGS="-L${EPREFIX}/usr/$(get_libdir) -L${EPREFIX}/$(get_libdir) ${LDFLAGS}" \
+ use X && setup-wxwidgets
+
+ append-libs -L"${ESYSROOT}"/usr/$(get_libdir) -L"${ESYSROOT}"/$(get_libdir)
+
econf --disable-server \
--enable-client \
--enable-dynamic-client-linkage \
@@ -137,7 +136,11 @@ src_install() {
# Create new icons. bug 593362
local s SIZES=(16 22 24 32 36 48 64 72 96 128 192 256)
for s in "${SIZES[@]}"; do
- convert "${DISTDIR}"/${PN}.tif -resize ${s}x${s} "${WORKDIR}"/boinc_${s}.png || die
+ # The convert command is not checked, because it will issue warnings and exit with
+ # an error code if imagemagick is used and was merged with USE="-xml", although the
+ # conversion has worked. See #766093
+ # Instead, newicon will fail if the conversion did not produce the icon.
+ convert "${DISTDIR}"/${PN}.tif -resize ${s}x${s} "${WORKDIR}"/boinc_${s}.png
newicon -s $s "${WORKDIR}"/boinc_${s}.png boinc.png
done
make_desktop_entry boincmgr "${PN}" "${PN}" "Math;Science" "Path=/var/lib/${PN}"