summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-04-28 20:51:52 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-04-28 20:51:52 +0200
commit7430920ad46eca2df4b62431b3309540ac349168 (patch)
tree85cc7783704e5c2a5e188e10f3753f457b3d7ef2 /sci-misc
parentdev-lang/mujs: add 1.1.2 (diff)
downloadgentoo-7430920ad46eca2df4b62431b3309540ac349168.tar.gz
gentoo-7430920ad46eca2df4b62431b3309540ac349168.tar.bz2
gentoo-7430920ad46eca2df4b62431b3309540ac349168.zip
sci-misc/flashdot: fix new ocaml - but still does not build
Closes: https://bugs.gentoo.org/770799 Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/flashdot/files/flashdot-1.1.4-ocaml-4.09.patch11
-rw-r--r--sci-misc/flashdot/flashdot-1.1.4-r1.ebuild3
2 files changed, 13 insertions, 1 deletions
diff --git a/sci-misc/flashdot/files/flashdot-1.1.4-ocaml-4.09.patch b/sci-misc/flashdot/files/flashdot-1.1.4-ocaml-4.09.patch
new file mode 100644
index 000000000000..8b00b86d52b7
--- /dev/null
+++ b/sci-misc/flashdot/files/flashdot-1.1.4-ocaml-4.09.patch
@@ -0,0 +1,11 @@
+--- a/fls/fls.ml 2021-04-26 16:24:25.363442099 +0200
++++ b/fls/fls.ml 2021-04-26 20:10:54.965405870 +0200
+@@ -750,7 +750,7 @@
+ match input inp s 0 1024 with
+ 0 -> Buffer.contents res
+ | n ->
+- Buffer.add_substring res s 0 n;
++ Buffer.add_subbytes res s 0 n;
+ fill_buff ()
+ in
+ let s = fill_buff () in
diff --git a/sci-misc/flashdot/flashdot-1.1.4-r1.ebuild b/sci-misc/flashdot/flashdot-1.1.4-r1.ebuild
index 97b4fd7fac5b..8d31eba90241 100644
--- a/sci-misc/flashdot/flashdot-1.1.4-r1.ebuild
+++ b/sci-misc/flashdot/flashdot-1.1.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -22,6 +22,7 @@ DEPEND="
RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}/${P}-gsl-ocaml.patch"
+ "${FILESDIR}"/${P}-ocaml-4.09.patch
)
src_prepare() {