summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-03-07 15:36:17 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-07 15:36:17 +0100
commit7f8156823984b5dae9058362bc42c4d6a41baac7 (patch)
treeee3adc2223a86e7c3c135de4cc49126cdbf8ef54 /sci-misc
parentsci-misc/apertium: Fix broken autotools (diff)
downloadgentoo-7f8156823984b5dae9058362bc42c4d6a41baac7.tar.gz
gentoo-7f8156823984b5dae9058362bc42c4d6a41baac7.tar.bz2
gentoo-7f8156823984b5dae9058362bc42c4d6a41baac7.zip
sci-misc/apertium: Port to EAPI 7
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/apertium/apertium-3.2.0.ebuild34
1 files changed, 24 insertions, 10 deletions
diff --git a/sci-misc/apertium/apertium-3.2.0.ebuild b/sci-misc/apertium/apertium-3.2.0.ebuild
index 997def4d182d..9efd69255cda 100644
--- a/sci-misc/apertium/apertium-3.2.0.ebuild
+++ b/sci-misc/apertium/apertium-3.2.0.ebuild
@@ -1,28 +1,25 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-AUTOTOOLS_AUTORECONF=true
-
-inherit autotools-utils
+inherit autotools
DESCRIPTION="Shallow-transfer machine Translation engine and toolbox"
HOMEPAGE="http://apertium.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="static-libs"
RDEPEND="
dev-libs/libxslt
dev-libs/libpcre[cxx]
>=sci-misc/lttoolbox-3.2
virtual/libiconv"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${PV}-flags.patch
@@ -31,5 +28,22 @@ PATCHES=(
"${FILESDIR}"/${P}-autotools.patch
)
-MAKEOPTS+=" -j1"
-AUTOTOOLS_IN_SOURCE_BUILD=1
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}