summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2016-01-12 16:59:11 -0200
committerGuilherme Amadio <amadio@gentoo.org>2016-01-12 16:59:11 -0200
commit55f0ddb40de3b898c62a2c4d29631a49064f2040 (patch)
tree2de6c24e5917ca41ecab864fd261f6b55d12bc32 /sci-physics/clhep/clhep-2.3.1.0.ebuild
parentapp-doc/geant-docs: version bump to 4.10.2 (diff)
downloadgentoo-55f0ddb40de3b898c62a2c4d29631a49064f2040.tar.gz
gentoo-55f0ddb40de3b898c62a2c4d29631a49064f2040.tar.bz2
gentoo-55f0ddb40de3b898c62a2c4d29631a49064f2040.zip
sci-physics/clhep: version bump to 2.3.1.0
Package-Manager: portage-2.2.26
Diffstat (limited to 'sci-physics/clhep/clhep-2.3.1.0.ebuild')
-rw-r--r--sci-physics/clhep/clhep-2.3.1.0.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sci-physics/clhep/clhep-2.3.1.0.ebuild b/sci-physics/clhep/clhep-2.3.1.0.ebuild
new file mode 100644
index 000000000000..abccb99dda60
--- /dev/null
+++ b/sci-physics/clhep/clhep-2.3.1.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils multilib
+
+DESCRIPTION="High Energy Physics C++ library"
+HOMEPAGE="http://www.cern.ch/clhep"
+SRC_URI="http://proj-clhep.web.cern.ch/proj-clhep/DISTRIBUTION/tarFiles/${P}.tgz"
+LICENSE="GPL-3 LGPL-3"
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc static-libs test"
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base )"
+
+S="${WORKDIR}/${PV}/CLHEP"
+
+src_prepare() {
+ # respect flags
+ sed -i -e 's:-O::g' cmake/Modules/ClhepVariables.cmake || die
+ # no batch mode to allow parallel building (bug #437482)
+ sed -i \
+ -e 's:-interaction=batchmode::g' \
+ cmake/Modules/ClhepBuildTex.cmake || die
+ # gentoo doc directory
+ sed -i \
+ -e "/DESTINATION/s:doc:share/doc/${PF}:" \
+ cmake/Modules/ClhepBuildTex.cmake */doc/CMakeLists.txt || die
+ # dont build test if not asked
+ if ! use test; then
+ sed -i \
+ -e '/add_subdirectory(test)/d' \
+ */CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable test TESTING)
+ $(cmake-utils_use doc CLHEP_BUILD_DOCS)
+ )
+ DESTDIR="${ED}" cmake-utils_src_configure
+ use doc && MAKEOPTS+=" -j1"
+}
+
+src_install() {
+ cmake-utils_src_install
+ use static-libs || rm "${ED}"/usr/$(get_libdir)/*.a
+}