summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-10-15 20:09:07 -0700
committerDavid Seifert <soap@gentoo.org>2017-10-15 20:09:07 -0700
commit0d7e40bd713a21633c73a7de7ce0b2fa2a01d03f (patch)
tree84c897eff45d83a7836bf7679d594c0b047b249b /sci-physics/clhep
parentsci-libs/superlu: [QA] Add cmake-utils_src_prepare (diff)
downloadgentoo-0d7e40bd713a21633c73a7de7ce0b2fa2a01d03f.tar.gz
gentoo-0d7e40bd713a21633c73a7de7ce0b2fa2a01d03f.tar.bz2
gentoo-0d7e40bd713a21633c73a7de7ce0b2fa2a01d03f.zip
sci-physics/clhep: [QA] Add cmake-utils_src_prepare
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'sci-physics/clhep')
-rw-r--r--sci-physics/clhep/clhep-2.1.4.1.ebuild4
-rw-r--r--sci-physics/clhep/clhep-2.1.4.2.ebuild2
-rw-r--r--sci-physics/clhep/clhep-2.2.0.1.ebuild2
-rw-r--r--sci-physics/clhep/clhep-2.2.0.5.ebuild2
-rw-r--r--sci-physics/clhep/clhep-2.3.1.0.ebuild2
-rw-r--r--sci-physics/clhep/clhep-2.3.3.1.ebuild2
6 files changed, 13 insertions, 1 deletions
diff --git a/sci-physics/clhep/clhep-2.1.4.1.ebuild b/sci-physics/clhep/clhep-2.1.4.1.ebuild
index b790902eb456..39ae660ca9b0 100644
--- a/sci-physics/clhep/clhep-2.1.4.1.ebuild
+++ b/sci-physics/clhep/clhep-2.1.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -20,6 +20,8 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${PV}/CLHEP"
src_prepare() {
+ cmake-utils_src_prepare
+
# respect flags
sed -i -e 's:-O::g' cmake/Modules/ClhepVariables.cmake || die
# no batch mode to allow parallel building (bug #437482)
diff --git a/sci-physics/clhep/clhep-2.1.4.2.ebuild b/sci-physics/clhep/clhep-2.1.4.2.ebuild
index 39b91169a162..fc50b6a42203 100644
--- a/sci-physics/clhep/clhep-2.1.4.2.ebuild
+++ b/sci-physics/clhep/clhep-2.1.4.2.ebuild
@@ -20,6 +20,8 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${PV}/CLHEP"
src_prepare() {
+ cmake-utils_src_prepare
+
# respect flags
sed -i -e 's:-O::g' cmake/Modules/ClhepVariables.cmake || die
# no batch mode to allow parallel building (bug #437482)
diff --git a/sci-physics/clhep/clhep-2.2.0.1.ebuild b/sci-physics/clhep/clhep-2.2.0.1.ebuild
index 39b91169a162..fc50b6a42203 100644
--- a/sci-physics/clhep/clhep-2.2.0.1.ebuild
+++ b/sci-physics/clhep/clhep-2.2.0.1.ebuild
@@ -20,6 +20,8 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${PV}/CLHEP"
src_prepare() {
+ cmake-utils_src_prepare
+
# respect flags
sed -i -e 's:-O::g' cmake/Modules/ClhepVariables.cmake || die
# no batch mode to allow parallel building (bug #437482)
diff --git a/sci-physics/clhep/clhep-2.2.0.5.ebuild b/sci-physics/clhep/clhep-2.2.0.5.ebuild
index f21569474620..35c47db6a89d 100644
--- a/sci-physics/clhep/clhep-2.2.0.5.ebuild
+++ b/sci-physics/clhep/clhep-2.2.0.5.ebuild
@@ -20,6 +20,8 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${PV}/CLHEP"
src_prepare() {
+ cmake-utils_src_prepare
+
# respect flags
sed -i -e 's:-O::g' cmake/Modules/ClhepVariables.cmake || die
# no batch mode to allow parallel building (bug #437482)
diff --git a/sci-physics/clhep/clhep-2.3.1.0.ebuild b/sci-physics/clhep/clhep-2.3.1.0.ebuild
index 39b91169a162..fc50b6a42203 100644
--- a/sci-physics/clhep/clhep-2.3.1.0.ebuild
+++ b/sci-physics/clhep/clhep-2.3.1.0.ebuild
@@ -20,6 +20,8 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${PV}/CLHEP"
src_prepare() {
+ cmake-utils_src_prepare
+
# respect flags
sed -i -e 's:-O::g' cmake/Modules/ClhepVariables.cmake || die
# no batch mode to allow parallel building (bug #437482)
diff --git a/sci-physics/clhep/clhep-2.3.3.1.ebuild b/sci-physics/clhep/clhep-2.3.3.1.ebuild
index 5238ed7061c7..e284870ec6ae 100644
--- a/sci-physics/clhep/clhep-2.3.3.1.ebuild
+++ b/sci-physics/clhep/clhep-2.3.3.1.ebuild
@@ -20,6 +20,8 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${PV}/CLHEP"
src_prepare() {
+ cmake-utils_src_prepare
+
# respect flags
sed -i -e 's:-O::g' cmake/Modules/ClhepVariables.cmake || die
# dont build test if not asked