summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-07-17 20:17:08 +0200
committerDavid Seifert <soap@gentoo.org>2021-07-17 20:17:08 +0200
commit5d48bc3167868ca93664326e445f8ac58650a1fd (patch)
treead6ed96bb2f2e5eb1a2a2545e21daeacc1e457fe /sci-physics/espresso
parentsci-misc/vitables: PYTHON_MULTI_USEDEP -> PYTHON_USEDEP (diff)
downloadgentoo-5d48bc3167868ca93664326e445f8ac58650a1fd.tar.gz
gentoo-5d48bc3167868ca93664326e445f8ac58650a1fd.tar.bz2
gentoo-5d48bc3167868ca93664326e445f8ac58650a1fd.zip
sci-physics/espresso: PYTHON_MULTI_USEDEP -> PYTHON_USEDEP
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-physics/espresso')
-rw-r--r--sci-physics/espresso/espresso-4.1.3.ebuild6
-rw-r--r--sci-physics/espresso/espresso-9999.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/sci-physics/espresso/espresso-4.1.3.ebuild b/sci-physics/espresso/espresso-4.1.3.ebuild
index a60bb434ef8b..19e9be04e85a 100644
--- a/sci-physics/espresso/espresso-4.1.3.ebuild
+++ b/sci-physics/espresso/espresso-4.1.3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8,9} )
CMAKE_MAKEFILE_GENERATOR="emake"
inherit cmake cuda python-single-r1 savedconfig
@@ -31,8 +31,8 @@ REQUIRED_USE="
RDEPEND="
${PYTHON_DEPS}
$(python_gen_cond_dep '
- >=dev-python/cython-0.26.1[${PYTHON_MULTI_USEDEP}]
- dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/cython-0.26.1[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
')
cuda? ( >=dev-util/nvidia-cuda-toolkit-4.2.9-r1 )
fftw? ( sci-libs/fftw:3.0 )
diff --git a/sci-physics/espresso/espresso-9999.ebuild b/sci-physics/espresso/espresso-9999.ebuild
index a60bb434ef8b..19e9be04e85a 100644
--- a/sci-physics/espresso/espresso-9999.ebuild
+++ b/sci-physics/espresso/espresso-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8,9} )
CMAKE_MAKEFILE_GENERATOR="emake"
inherit cmake cuda python-single-r1 savedconfig
@@ -31,8 +31,8 @@ REQUIRED_USE="
RDEPEND="
${PYTHON_DEPS}
$(python_gen_cond_dep '
- >=dev-python/cython-0.26.1[${PYTHON_MULTI_USEDEP}]
- dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/cython-0.26.1[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
')
cuda? ( >=dev-util/nvidia-cuda-toolkit-4.2.9-r1 )
fftw? ( sci-libs/fftw:3.0 )