summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2016-07-23 17:11:57 -0600
committerChristoph Junghans <ottxor@gentoo.org>2016-07-23 17:12:14 -0600
commite76c985ed55cdc692b3b49c508eee8d2b5fdfa07 (patch)
tree21096244a856caace3fe0ec124a40eb0b6cfff40 /sci-physics/hoomd-blue/hoomd-blue-9999.ebuild
parentwww-apps/airdcpp-webui: remove old (diff)
downloadgentoo-e76c985ed55cdc692b3b49c508eee8d2b5fdfa07.tar.gz
gentoo-e76c985ed55cdc692b3b49c508eee8d2b5fdfa07.tar.bz2
gentoo-e76c985ed55cdc692b3b49c508eee8d2b5fdfa07.zip
sci-physics/hoomd-blue: add multi-py build
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-physics/hoomd-blue/hoomd-blue-9999.ebuild')
-rw-r--r--sci-physics/hoomd-blue/hoomd-blue-9999.ebuild38
1 files changed, 28 insertions, 10 deletions
diff --git a/sci-physics/hoomd-blue/hoomd-blue-9999.ebuild b/sci-physics/hoomd-blue/hoomd-blue-9999.ebuild
index e126c82634de..124046213cd8 100644
--- a/sci-physics/hoomd-blue/hoomd-blue-9999.ebuild
+++ b/sci-physics/hoomd-blue/hoomd-blue-9999.ebuild
@@ -7,7 +7,7 @@ EAPI=6
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
CMAKE_MAKEFILE_GENERATOR="ninja"
-inherit cmake-utils cuda flag-o-matic python-single-r1
+inherit cmake-utils cuda flag-o-matic python-r1
DESCRIPTION="a general-purpose particle simulation toolkit"
HOMEPAGE="http://codeblue.umich.edu/hoomd-blue/"
@@ -40,16 +40,34 @@ src_prepare() {
[[ ${PV} = 9999 ]] || mv ../libgetar-${GETTAR_VER}/* hoomd/extern/libgetar || die
use cuda && cuda_src_prepare
cmake-utils_src_prepare
+
+ #https://bitbucket.org/glotzer/hoomd-blue/issues/173
+ append-cxxflags -std=gnu++11
}
src_configure() {
- local mycmakeargs=(
- -DENABLE_MPI=$(usex mpi)
- -DENABLE_CUDA=$(usex cuda)
- -DBUILD_TESTING=$(usex test)
- -DPYTHON_EXECUTABLE="${PYTHON}"
- -DCMAKE_INSTALL_PREFIX=$(python_get_sitedir)
- -DUPDATE_SUBMODULES=OFF
- )
- cmake-utils_src_configure
+ src_configure_internal() {
+ local mycmakeargs=(
+ -DENABLE_MPI=$(usex mpi)
+ -DENABLE_CUDA=$(usex cuda)
+ -DBUILD_TESTING=$(usex test)
+ -DUPDATE_SUBMODULES=OFF
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DCMAKE_INSTALL_PREFIX=$(python_get_sitedir)
+ )
+ cmake-utils_src_configure
+ }
+ python_foreach_impl src_configure_internal
+}
+
+src_compile() {
+ python_foreach_impl cmake-utils_src_make
+}
+
+src_test() {
+ python_foreach_impl cmake-utils_src_test
+}
+
+src_install() {
+ python_foreach_impl cmake-utils_src_install
}