summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2018-08-24 14:29:11 +0200
committerGuilherme Amadio <amadio@gentoo.org>2018-08-24 14:57:29 +0200
commitcccdcc6be767853b136dc5e2cbda15e170d030e6 (patch)
treef734a6aee8d59ed7b8a1e3354421625e3cd63e2a /sci-physics/root
parentsci-physics/root: update REQUIRED_USE (diff)
downloadgentoo-cccdcc6be767853b136dc5e2cbda15e170d030e6.tar.gz
gentoo-cccdcc6be767853b136dc5e2cbda15e170d030e6.tar.bz2
gentoo-cccdcc6be767853b136dc5e2cbda15e170d030e6.zip
sci-physics/root: enable support for nVidia CUDA
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'sci-physics/root')
-rw-r--r--sci-physics/root/metadata.xml1
-rw-r--r--sci-physics/root/root-6.14.02.ebuild10
-rw-r--r--sci-physics/root/root-9999.ebuild10
3 files changed, 13 insertions, 8 deletions
diff --git a/sci-physics/root/metadata.xml b/sci-physics/root/metadata.xml
index 46ddf2da381c..baf90a1a37bc 100644
--- a/sci-physics/root/metadata.xml
+++ b/sci-physics/root/metadata.xml
@@ -21,6 +21,7 @@
</longdescription>
<use>
<flag name="asimage">Enable support for <pkg>media-libs/libafterimage</pkg></flag>
+ <flag name="cuda">Enable support for nVidia CUDA</flag>
<flag name="davix">Enable support for DAVIX Data Management Client (https://cern.ch/davix)</flag>
<flag name="fits">Enable support for images and data from FITS files with <pkg>sci-libs/cfitsio</pkg></flag>
<flag name="fortran">Compile included Fortran programs</flag>
diff --git a/sci-physics/root/root-6.14.02.ebuild b/sci-physics/root/root-6.14.02.ebuild
index da5c95124981..24d19074d97b 100644
--- a/sci-physics/root/root-6.14.02.ebuild
+++ b/sci-physics/root/root-6.14.02.ebuild
@@ -9,14 +9,14 @@ CMAKE_MAKEFILE_GENERATOR=emake
FORTRAN_NEEDED="fortran"
PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-inherit cmake-utils eapi7-ver elisp-common eutils fortran-2 \
+inherit cmake-utils cuda eapi7-ver elisp-common eutils fortran-2 \
prefix python-single-r1 toolchain-funcs
DESCRIPTION="C++ data analysis framework and interpreter from CERN"
HOMEPAGE="https://root.cern"
SRC_URI="https://root.cern/download/${PN}_v${PV}.source.tar.gz"
-IUSE="+X avahi aqua +asimage +davix emacs +examples fits fftw fortran
+IUSE="+X avahi aqua +asimage cuda +davix emacs +examples fits fftw fortran
+gdml graphviz +gsl http jemalloc kerberos ldap libcxx memstat
+minuit mysql odbc +opengl oracle postgres prefix pythia6 pythia8
+python qt5 R +roofit root7 shadow sqlite +ssl table +tbb test
@@ -68,6 +68,7 @@ CDEPEND="
>=x11-wm/afterstep-2.2.11[gif,jpeg,png,tiff?]
) )
avahi? ( net-dns/avahi[mdnsresponder-compat] )
+ cuda? ( >=dev-util/nvidia-cuda-toolkit-9.0 )
davix? ( net-libs/davix )
emacs? ( virtual/emacs )
fftw? ( sci-libs/fftw:3.0= )
@@ -189,6 +190,7 @@ src_configure() {
-Dchirp=OFF
-Dcling=ON # cling=OFF is broken
-Dcocoa=$(usex aqua)
+ -Dcuda=$(usex cuda)
-Dcxx14=$(usex root7)
-Dcxxmodules=OFF # requires clang, unstable
-Ddavix=$(usex davix)
@@ -250,9 +252,9 @@ src_configure() {
-Dtcmalloc=OFF
-Dtesting=$(usex test)
-Dthread=$(usex threads)
- -Dtmva-cpu=$(usex tmva)
- -Dtmva-gpu=OFF
-Dtmva=$(usex tmva)
+ -Dtmva-cpu=$(usex tmva)
+ -Dtmva-gpu=$(usex cuda)
-Dunuran=$(usex unuran)
-Dvc=$(usex vc)
-Dvdt=OFF
diff --git a/sci-physics/root/root-9999.ebuild b/sci-physics/root/root-9999.ebuild
index efb109007656..b9e470282f89 100644
--- a/sci-physics/root/root-9999.ebuild
+++ b/sci-physics/root/root-9999.ebuild
@@ -9,7 +9,7 @@ CMAKE_MAKEFILE_GENERATOR=emake
FORTRAN_NEEDED="fortran"
PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-inherit cmake-utils eapi7-ver elisp-common eutils fortran-2 \
+inherit cmake-utils cuda eapi7-ver elisp-common eutils fortran-2 \
prefix python-single-r1 toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
@@ -26,7 +26,7 @@ fi
DESCRIPTION="C++ data analysis framework and interpreter from CERN"
HOMEPAGE="https://root.cern"
-IUSE="+X avahi aqua +asimage +davix emacs +examples fits fftw fortran
+IUSE="+X avahi aqua +asimage cuda +davix emacs +examples fits fftw fortran
+gdml graphviz +gsl http jemalloc kerberos ldap libcxx memstat
+minuit mysql odbc +opengl oracle postgres prefix pythia6 pythia8
+python qt5 R +roofit root7 shadow sqlite +ssl table +tbb test
@@ -77,6 +77,7 @@ CDEPEND="
>=x11-wm/afterstep-2.2.11[gif,jpeg,png,tiff?]
) )
avahi? ( net-dns/avahi[mdnsresponder-compat] )
+ cuda? ( >=dev-util/nvidia-cuda-toolkit-9.0 )
davix? ( net-libs/davix )
emacs? ( virtual/emacs )
fftw? ( sci-libs/fftw:3.0= )
@@ -198,6 +199,7 @@ src_configure() {
-Dchirp=OFF
-Dcling=ON # cling=OFF is broken
-Dcocoa=$(usex aqua)
+ -Dcuda=$(usex cuda)
-Dcxx14=$(usex root7)
-Dcxxmodules=OFF # requires clang, unstable
-Ddavix=$(usex davix)
@@ -260,9 +262,9 @@ src_configure() {
-Dtcmalloc=OFF
-Dtesting=$(usex test)
-Dthread=$(usex threads)
- -Dtmva-cpu=$(usex tmva)
- -Dtmva-gpu=OFF
-Dtmva=$(usex tmva)
+ -Dtmva-cpu=$(usex tmva)
+ -Dtmva-gpu=$(usex cuda)
-Dunuran=$(usex unuran)
-Dvc=$(usex vc)
-Dvdt=OFF