summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-19 13:09:44 +0000
committerSam James <sam@gentoo.org>2021-02-19 13:09:44 +0000
commit56b74153c2b5838bac693d99e1805f32a8bac9e5 (patch)
treed84a54682374d9d17788017f10fbdefcfe2d9f0e /sci-physics/xfoil
parentsci-visualization/xd3d: workaround gcc 10 (fortran) failure (diff)
downloadgentoo-56b74153c2b5838bac693d99e1805f32a8bac9e5.tar.gz
gentoo-56b74153c2b5838bac693d99e1805f32a8bac9e5.tar.bz2
gentoo-56b74153c2b5838bac693d99e1805f32a8bac9e5.zip
sci-physics/xfoil: workaround gcc 10 (fortran) failure
Closes: https://bugs.gentoo.org/722194 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-physics/xfoil')
-rw-r--r--sci-physics/xfoil/xfoil-6.99.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sci-physics/xfoil/xfoil-6.99.ebuild b/sci-physics/xfoil/xfoil-6.99.ebuild
index 8826b940814c..36047f4e3d56 100644
--- a/sci-physics/xfoil/xfoil-6.99.ebuild
+++ b/sci-physics/xfoil/xfoil-6.99.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit fortran-2 toolchain-funcs
+inherit fortran-2 flag-o-matic toolchain-funcs
DESCRIPTION="Design and analysis of subsonic isolated airfoils"
HOMEPAGE="http://raphael.mit.edu/xfoil/"
@@ -28,6 +28,10 @@ src_prepare() {
[[ $(tc-getFC) == *gfortran ]] && PATCHES+=( "${FILESDIR}"/${PN}-6.96-gfortran.patch )
default
+ # GCC 10 workaround
+ # bug #722194
+ append-fflags $(test-flags-FC -fallow-argument-mismatch)
+
sed \
-e '/^FC/d' \
-e '/^CC/d' \