summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2016-01-11 17:06:26 -0200
committerGuilherme Amadio <amadio@gentoo.org>2016-01-11 17:11:22 -0200
commit28a5f3fe7ede7380212d3c7fe7c335d5f6736961 (patch)
tree1d878fcdb0022bc5416301dbbe7141a1395b8a61 /sci-physics
parentdev-libs/elfutils: version bump to 0.165 (diff)
downloadgentoo-28a5f3fe7ede7380212d3c7fe7c335d5f6736961.tar.gz
gentoo-28a5f3fe7ede7380212d3c7fe7c335d5f6736961.tar.bz2
gentoo-28a5f3fe7ede7380212d3c7fe7c335d5f6736961.zip
sci-physics/bullet: version bump to 2.83.5
Package-Manager: portage-2.2.26
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/bullet/Manifest1
-rw-r--r--sci-physics/bullet/bullet-2.83.5.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/sci-physics/bullet/Manifest b/sci-physics/bullet/Manifest
index 659ad7796d26..6422c32a4417 100644
--- a/sci-physics/bullet/Manifest
+++ b/sci-physics/bullet/Manifest
@@ -2,3 +2,4 @@ DIST bullet-2.80-rev2531.tgz 9561231 SHA256 464e2d79e3c5a5bdcad597ef6fca26d4244a
DIST bullet-2.81-rev2613.tgz 8297547 SHA256 8ac9079803a6f793801727ccddb0b98becea3efe92fd6590cf38b9cb8bbc1eed SHA512 5f77d4ea123bca06a390e27f5028d67b1f328c65d16711448cca885bc66de37bdef3024397603140e28e8fe68679cc596aa9a4ee617fc2a913f23d4c5c0f52a3 WHIRLPOOL 91894b76cb3cd4239f91305860cf78152c323df05c4b1d77bb8564cd2badb8a7e811f8dcf7e10f9b04db5345787b3c2cb0163d0ef9c77aa716e69307a235873a
DIST bullet-2.82-r2704.tgz 7937108 SHA256 67e4c9eb76f7adf99501d726d8ad5e9b525dfd0843fbce9ca73aaca4ba9eced2 SHA512 44bec0bd74e6d9cd8c75a41d0faa068dc05f0cdad92ff001cc53ff29912db245606827a9e763ce2cf1b551b545668a779fdc4455f73c1901b57aaa4eee31901f WHIRLPOOL 181c6bf35ba28333f66fba52faff2e7bfc634a702df4c9925123160d89058602e354e9c21a82c86fc166fab55254a70739e37220d28968a989ed94a52a6f7e39
DIST bullet-2.83.4.tar.gz 17529283 SHA256 2cf287cead9a116c56f6d6f15f73dc8b3ed1fe407ef2ca894027d585fab07341 SHA512 1a10a11671bd152835a45d44a1b3214e29c255338405705f2aaa41adfbdb545ec02f09b94003b836fafcc2b59b836e5b749696a5bb3489ec7050af0d02d9b2e1 WHIRLPOOL 7a472291128888fdd1c96e232b91d734ff10c2b6cf6ff0563bd3e6fa4c113112fe3f169dc0e42fee56aacf66b6717a10901f0c61c618a6c691bf1eb3cbcefbf2
+DIST bullet-2.83.5.tar.gz 17759627 SHA256 df6d58898d3d3bf117854dd64467dbd09625e048624c797649b46bf1c595b152 SHA512 9e1ca7b3afb700bfafc2d39d8ec8b004b5bae7788385e763c15a63a7754c50bfd79e1a6ab501569b613eb5a9c132688c747aa70db0b80099cfe40b6146c32290 WHIRLPOOL 6c304902dd6bc9e800befe5c214adcec48e068e6db288ddf211ce17af74abd8ebc44a34ee1349a17bd22e1f9c316782d7680bb55566b4100b2f788377921be29
diff --git a/sci-physics/bullet/bullet-2.83.5.ebuild b/sci-physics/bullet/bullet-2.83.5.ebuild
new file mode 100644
index 000000000000..98de17423b69
--- /dev/null
+++ b/sci-physics/bullet/bullet-2.83.5.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils cmake-utils
+
+DESCRIPTION="Continuous Collision Detection and Physics Library"
+HOMEPAGE="http://www.bulletphysics.com/"
+SRC_URI="https://github.com/bulletphysics/bullet3/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+bullet3 doc double-precision examples extras"
+
+RDEPEND="
+ virtual/opengl
+ media-libs/freeglut"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.78-soversion.patch )
+
+S="${WORKDIR}/${PN}3-${PV}"
+
+src_prepare() {
+ # allow to generate docs
+ sed -i -e 's/GENERATE_HTMLHELP.*//g' Doxyfile || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_CPU_DEMOS=OFF
+ -DBUILD_OPENGL3_DEMOS=OFF
+ -DBUILD_BULLET2_DEMOS=OFF
+ -DUSE_GRAPHICAL_BENCHMARK=OFF
+ -DINSTALL_LIBS=ON
+ -DINSTALL_EXTRA_LIBS=ON
+ $(cmake-utils_use_build bullet3 BULLET3)
+ $(cmake-utils_use_build extras EXTRAS)
+ $(cmake-utils_use_use double-precision DOUBLE_PRECISION)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc; then
+ doxygen || die
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc docs/*.pdf && dohtml -r html/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r Extras examples
+ fi
+}