summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2023-02-17 14:38:35 +0100
committerSam James <sam@gentoo.org>2023-02-19 19:55:47 +0000
commit34c58f997155323ca47d73f6d58213fa09a08b88 (patch)
tree003288ced6b5cabeb034606b59b3bfffedd55d07 /sci-physics
parentapp-portage/smart-live-rebuild: Bump to 1.4.1 (diff)
downloadgentoo-34c58f997155323ca47d73f6d58213fa09a08b88.tar.gz
gentoo-34c58f997155323ca47d73f6d58213fa09a08b88.tar.bz2
gentoo-34c58f997155323ca47d73f6d58213fa09a08b88.zip
sci-physics/fastjet-contrib: uint -> unsigned int
Closes: https://bugs.gentoo.org/873646 Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de> Closes: https://github.com/gentoo/gentoo/pull/29633 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/fastjet-contrib/fastjet-contrib-1.049-r2.ebuild45
-rw-r--r--sci-physics/fastjet-contrib/files/fastjet-contrib-1.049-musl.patch11
2 files changed, 56 insertions, 0 deletions
diff --git a/sci-physics/fastjet-contrib/fastjet-contrib-1.049-r2.ebuild b/sci-physics/fastjet-contrib/fastjet-contrib-1.049-r2.ebuild
new file mode 100644
index 000000000000..e21a08bc6b6b
--- /dev/null
+++ b/sci-physics/fastjet-contrib/fastjet-contrib-1.049-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=fjcontrib
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="3rd party extensions of FastJet."
+HOMEPAGE="https://fastjet.hepforge.org/contrib/"
+SRC_URI="https://fastjet.hepforge.org/contrib/downloads/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=sci-physics/fastjet-3.4.0"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-soname.patch
+ "${FILESDIR}"/${P}-ar.patch
+ "${FILESDIR}"/${P}-musl.patch
+)
+
+src_configure() {
+ tc-export CXX AR RANLIB
+ ./configure --prefix=/usr --fastjet-config=/usr/bin/fastjet-config RANLIB="${RANLIB}" AR="${AR}" CXX="${CXX}" CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" FFLAGS="${FFLAGS}" LDFLAGS="${LDFLAGS}" || die
+}
+
+src_compile() {
+ emake
+ emake fragile-shared
+}
+
+src_install() {
+ emake install PREFIX="${ED}/usr"
+ dolib.so libfastjetcontribfragile.so
+ # The name used for requesting this library varies
+ dosym libfastjetcontribfragile.so /usr/$(get_libdir)/libfastjetcontribfragile.so.0
+ dosym libfastjetcontribfragile.so /usr/$(get_libdir)/fastjetcontribfragile.so.0
+}
diff --git a/sci-physics/fastjet-contrib/files/fastjet-contrib-1.049-musl.patch b/sci-physics/fastjet-contrib/files/fastjet-contrib-1.049-musl.patch
new file mode 100644
index 000000000000..880e145ba060
--- /dev/null
+++ b/sci-physics/fastjet-contrib/files/fastjet-contrib-1.049-musl.patch
@@ -0,0 +1,11 @@
+--- a/LundPlane/example_dpsi_slice.cc
++++ b/LundPlane/example_dpsi_slice.cc
+@@ -124,7 +124,7 @@
+
+ int index_of_max_kt_secondary = -1;
+ double dpsi;
+- for (uint i_secondary=0; i_secondary<secondaries.size(); i_secondary++) {
++ for (unsigned int i_secondary=0; i_secondary<secondaries.size(); i_secondary++) {
+ if (secondaries[i_secondary]->z() > z2_cut) {
+
+ index_of_max_kt_secondary = i_secondary;