summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-21 16:00:42 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-21 16:04:16 +0200
commit49a112b93c6d310d5dfe4dba696db2f2304784ba (patch)
tree4829267b39b56fe943afa149051d5af315e51e2b /sci-physics
parentsci-visualization/yt: Remove last-rited pkg (diff)
downloadgentoo-49a112b93c6d310d5dfe4dba696db2f2304784ba.tar.gz
gentoo-49a112b93c6d310d5dfe4dba696db2f2304784ba.tar.bz2
gentoo-49a112b93c6d310d5dfe4dba696db2f2304784ba.zip
sci-physics/qutip: Remove last-rited pkg
Closes: https://bugs.gentoo.org/718508 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/qutip/Manifest1
-rw-r--r--sci-physics/qutip/metadata.xml14
-rw-r--r--sci-physics/qutip/qutip-4.2.0.ebuild51
3 files changed, 0 insertions, 66 deletions
diff --git a/sci-physics/qutip/Manifest b/sci-physics/qutip/Manifest
deleted file mode 100644
index 2cc76f67623d..000000000000
--- a/sci-physics/qutip/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST qutip-4.2.0.tar.gz 424805 BLAKE2B 8f85e12402681b57bd4a612a2d5d9023f4c27a35aa78b70ad00d238123b2863a9b728e5ed1c24d81faf6892ca2b0a5b70652403fbd7b5dc02629e328e92a7e2b SHA512 888e569b30a1085162ecfa768967526f5ce34b19e1a1b0f76f1331eb3978159ba321e126a1bc57e0936c5819218f07a336a57c80193b33af1009d1cd87fa95de
diff --git a/sci-physics/qutip/metadata.xml b/sci-physics/qutip/metadata.xml
deleted file mode 100644
index d20d38f47016..000000000000
--- a/sci-physics/qutip/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription lang="en">
- QuTiP is open-source software for simulating the dynamics of open quantum systems. The QuTiP library depends on the excellent Numpy, Scipy, and Cython numerical packages. In addition, graphical output is provided by Matplotlib. QuTiP aims to provide user-friendly and efficient numerical simulations of a wide variety of Hamiltonians, including those with arbitrary time-dependence, commonly found in a wide range of physics applications such as quantum optics, trapped ions, superconducting circuits, and quantum nanomechanical resonators.
- </longdescription>
- <upstream>
- <remote-id type="github">qutip/qutip</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/sci-physics/qutip/qutip-4.2.0.ebuild b/sci-physics/qutip/qutip-4.2.0.ebuild
deleted file mode 100644
index 6e022cd8d0fb..000000000000
--- a/sci-physics/qutip/qutip-4.2.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1 toolchain-funcs
-
-DESCRIPTION="Simulating dynamics of open quantum systems in Python."
-HOMEPAGE="http://qutip.org"
-SRC_URI="https://github.com/qutip/qutip/archive/v$PV.tar.gz -> $P.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="openmp test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/cython[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-python_prepare_all() {
- sed -i setup.py \
- -e 's/_compiler_flags = .*$/_compiler_flags = []/' || die
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- use openmp && mydistutilsargs=( --with-openmp )
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib* || die
- ${EPYTHON} -c "import qutip.testing as qt ; qt.run()" || die
-}