summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-16 11:50:03 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-16 12:04:58 +0200
commit811700044421890b5085b1f15cd8a51cd39d8909 (patch)
tree049f3c83385999e3c1ebf1d66e5d3f59fedf9eb4 /sci-physics
parentsci-physics/yoda: Remove old (diff)
downloadgentoo-811700044421890b5085b1f15cd8a51cd39d8909.tar.gz
gentoo-811700044421890b5085b1f15cd8a51cd39d8909.tar.bz2
gentoo-811700044421890b5085b1f15cd8a51cd39d8909.zip
sci-physics/yoda: Disable python2
Closes: https://bugs.gentoo.org/735196 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/yoda/yoda-1.7.0-r2.ebuild (renamed from sci-physics/yoda/yoda-1.7.0-r1.ebuild)29
1 files changed, 10 insertions, 19 deletions
diff --git a/sci-physics/yoda/yoda-1.7.0-r1.ebuild b/sci-physics/yoda/yoda-1.7.0-r2.ebuild
index a29234715ba0..918658484a9a 100644
--- a/sci-physics/yoda/yoda-1.7.0-r1.ebuild
+++ b/sci-physics/yoda/yoda-1.7.0-r2.ebuild
@@ -3,9 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit bash-completion-r1 python-single-r1
+inherit bash-completion-r1
DESCRIPTION="Yet more Objects for (High Energy Physics) Data Analysis"
HOMEPAGE="http://yoda.hepforge.org/"
@@ -15,33 +13,26 @@ LICENSE="GPL-2"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="python root static-libs"
+IUSE="root static-libs"
RDEPEND="
- python? ( ${PYTHON_DEPS} )
- root? ( sci-physics/root:=[python=,${PYTHON_SINGLE_USEDEP}] )"
-DEPEND="${RDEPEND}
- python? (
- $(python_gen_cond_dep '
- dev-python/cython[${PYTHON_MULTI_USEDEP}]
- ')
- )"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+ root? ( sci-physics/root:= )"
+DEPEND="${RDEPEND}"
S="${WORKDIR}/${P^^}"
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
src_configure() {
econf \
- $(use_enable python pyext) \
+ --disable-pyext \
$(use_enable root) \
$(use_enable static-libs static)
}
+src_test() {
+ # PYTESTS and SHTESTS both require python tools
+ emake check PYTESTS= SHTESTS=
+}
+
src_install() {
default
newbashcomp "${ED%/}"/usr/share/YODA/yoda-completion ${PN}