summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2020-06-20 19:51:42 +0200
committerGuilherme Amadio <amadio@gentoo.org>2020-06-20 19:51:56 +0200
commit8caf86846d40011171c4967b7b4047884c9540af (patch)
tree859e1a7d8e43147ce38c34b86144fa3bf7c69684 /sci-physics
parentdev-db/pgxnclient: Add missing test deps (diff)
downloadgentoo-8caf86846d40011171c4967b7b4047884c9540af.tar.gz
gentoo-8caf86846d40011171c4967b7b4047884c9540af.tar.bz2
gentoo-8caf86846d40011171c4967b7b4047884c9540af.zip
sci-physics/root: fix bug #728372
Closes: https://bugs.gentoo.org/728372 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/root/files/root-6.22.00-rlogger.patch36
-rw-r--r--sci-physics/root/root-6.22.00.ebuild1
2 files changed, 37 insertions, 0 deletions
diff --git a/sci-physics/root/files/root-6.22.00-rlogger.patch b/sci-physics/root/files/root-6.22.00-rlogger.patch
new file mode 100644
index 000000000000..8ff25c86b521
--- /dev/null
+++ b/sci-physics/root/files/root-6.22.00-rlogger.patch
@@ -0,0 +1,36 @@
+From bea87d2cde7c490c8417a97f043eaa6905c27f08 Mon Sep 17 00:00:00 2001
+From: Axel Naumann <Axel.Naumann@cern.ch>
+Date: Wed, 3 Jun 2020 16:38:49 +0200
+Subject: [PATCH] [cmake] Fix ROOT/RLogger.hxx not found:
+
+When building without root7 but with C++14, RLogger is used.
+Make it available to the include directories.
+
+(cherry picked from commit fbe075ceedcd7d7f9993864c82ac5bd2960f3494)
+---
+ core/base/CMakeLists.txt | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/core/base/CMakeLists.txt b/core/base/CMakeLists.txt
+index 66ec9a2224..95eea9b44a 100644
+--- a/core/base/CMakeLists.txt
++++ b/core/base/CMakeLists.txt
+@@ -198,6 +198,7 @@ set(BASE_SOURCES
+ if(CMAKE_CXX_STANDARD GREATER 11)
+ list(APPEND BASE_HEADERS ROOT/RLogger.hxx)
+ list(APPEND BASE_SOURCES v7/src/RLogger.cxx)
++ set(BASE_V7_INC ${CMAKE_SOURCE_DIR}/core/base/v7/inc)
+ # TLogger.hxx may be used without root7 flag, but is placed in v7/inc/,
+ # so we need to tell ROOT_INSTALL_HEADERS() where to find it
+ set(BASE_HEADER_DIRS inc/ v7/inc/)
+@@ -220,6 +221,7 @@ set(Core_dict_headers ${BASE_HEADERS} PARENT_SCOPE)
+ ROOT_OBJECT_LIBRARY(Base ${BASE_SOURCES})
+
+ target_include_directories(Base PRIVATE
++ ${BASE_V7_INC}
+ ${PCRE_INCLUDE_DIR}
+ res
+ ${CMAKE_SOURCE_DIR}/core/foundation/res
+--
+2.27.0
+
diff --git a/sci-physics/root/root-6.22.00.ebuild b/sci-physics/root/root-6.22.00.ebuild
index bc8ff3c8c0f5..f81b66760847 100644
--- a/sci-physics/root/root-6.22.00.ebuild
+++ b/sci-physics/root/root-6.22.00.ebuild
@@ -110,6 +110,7 @@ RDEPEND="${CDEPEND}"
PATCHES=(
"${FILESDIR}"/${PN}-6.12.06_cling-runtime-sysroot.patch
+ "${FILESDIR}"/${PN}-6.22.00-rlogger.patch
)
pkg_setup() {