summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-01-19 08:30:44 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-01-19 08:30:44 +0100
commit936ffe3af825714c24cbc2f5de1acaebf1d568e9 (patch)
treea6e057860fab1b9ea90a637b378c2f1f7845e099 /sci-physics
parentdev-ruby/rails: add 6.0.6.1 (diff)
downloadgentoo-936ffe3af825714c24cbc2f5de1acaebf1d568e9.tar.gz
gentoo-936ffe3af825714c24cbc2f5de1acaebf1d568e9.tar.bz2
gentoo-936ffe3af825714c24cbc2f5de1acaebf1d568e9.zip
sci-physics/lhapdf: drop 6.3.0
Closes: https://bugs.gentoo.org/870139 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/lhapdf/lhapdf-6.3.0.ebuild81
1 files changed, 0 insertions, 81 deletions
diff --git a/sci-physics/lhapdf/lhapdf-6.3.0.ebuild b/sci-physics/lhapdf/lhapdf-6.3.0.ebuild
deleted file mode 100644
index 954144b95a18..000000000000
--- a/sci-physics/lhapdf/lhapdf-6.3.0.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_9 )
-DISTUTILS_USE_SETUPTOOLS=no
-inherit distutils-r1
-
-MY_PV=$(ver_cut 1-3)
-MY_PF=LHAPDF-${MY_PV}
-
-DESCRIPTION="Les Houches Parton Density Function unified library"
-HOMEPAGE="http://lhapdf.hepforge.org/"
-SRC_URI="http://www.hepforge.org/archive/lhapdf/${MY_PF}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples python"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- dev-libs/boost:=
- python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}"
-BDEPEND="
- doc? (
- app-doc/doxygen
- dev-texlive/texlive-bibtexextra
- dev-texlive/texlive-fontsextra
- dev-texlive/texlive-fontutils
- dev-texlive/texlive-latex
- dev-texlive/texlive-latexextra
- )"
-
-S="${WORKDIR}/${MY_PF}"
-
-src_configure() {
- CONFIG_SHELL="${EPREFIX}/bin/bash" \
- econf \
- --disable-static \
- $(use_enable python)
-
- if use python; then
- cd "${S}"/wrappers/python || die
- distutils-r1_src_prepare
- fi
-}
-
-src_compile() {
- emake all $(use doc && echo doxy)
-
- if use python; then
- cd "${S}"/wrappers/python || die
- distutils-r1_src_compile
- fi
-}
-
-src_test() {
- emake -C tests
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- use doc && dodoc -r doc/doxygen/.
- use examples && doins examples/*.cc
-
- if use python; then
- cd "${S}"/wrappers/python || die
- distutils-r1_src_install
- fi
-
- find "${ED}" -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- elog "Download data files from:"
- elog "http://www.hepforge.org/archive/${PN}/pdfsets/$(ver_cut 1-2)"
- elog "and untar them into ${EPREFIX}/usr/share/LHAPDF"
-}