summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-04-11 22:48:11 +0200
committerDavid Seifert <soap@gentoo.org>2019-04-11 22:48:53 +0200
commitbc9d0ab7531be52dcde085e832feac2f3a9b7e99 (patch)
tree02385071cdc997165fb6c720315269ef065fc3be /sci-visualization/gle
parentdev-ruby/facter: 3.13.2 bump (diff)
downloadgentoo-bc9d0ab7531be52dcde085e832feac2f3a9b7e99.tar.gz
gentoo-bc9d0ab7531be52dcde085e832feac2f3a9b7e99.tar.bz2
gentoo-bc9d0ab7531be52dcde085e832feac2f3a9b7e99.zip
sci-visualization/gle: Fix building with media-libs/jpeg
Closes: https://bugs.gentoo.org/647626 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-visualization/gle')
-rw-r--r--sci-visualization/gle/files/gle-4.2.5-jpeg-9c.patch22
-rw-r--r--sci-visualization/gle/gle-4.2.5-r1.ebuild10
2 files changed, 28 insertions, 4 deletions
diff --git a/sci-visualization/gle/files/gle-4.2.5-jpeg-9c.patch b/sci-visualization/gle/files/gle-4.2.5-jpeg-9c.patch
new file mode 100644
index 000000000000..c5dd2205dc43
--- /dev/null
+++ b/sci-visualization/gle/files/gle-4.2.5-jpeg-9c.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/647626
+
+--- a/src/gle/gle-poppler.cpp
++++ b/src/gle/gle-poppler.cpp
+@@ -194,7 +194,7 @@
+ boolean gle_jpeg_empty_output_buffer(j_compress_ptr cinfo) {
+ gle_jpeg_term_destination(cinfo);
+ gle_jpeg_init_destination(cinfo);
+- return true;
++ return TRUE;
+ }
+
+ void gle_jpeg_memory_dest(j_compress_ptr cinfo, JOCTET* buffer, GLEWriteFuncAndClosure writeCallback) {
+@@ -237,7 +237,7 @@
+ cinfo.in_color_space = JCS_RGB;
+ }
+ jpeg_set_defaults(&cinfo);
+- jpeg_start_compress(&cinfo, true);
++ jpeg_start_compress(&cinfo, TRUE);
+ JSAMPROW row = new JSAMPLE[cinfo.input_components * width];
+ JSAMPROW row_pointer[1];
+ row_pointer[0] = row;
diff --git a/sci-visualization/gle/gle-4.2.5-r1.ebuild b/sci-visualization/gle/gle-4.2.5-r1.ebuild
index c9157c018093..f0d2a19ba6ab 100644
--- a/sci-visualization/gle/gle-4.2.5-r1.ebuild
+++ b/sci-visualization/gle/gle-4.2.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -30,9 +30,11 @@ RDEPEND="${DEPEND}
S="${WORKDIR}"/${MY_P}
-PATCHES=( "${FILESDIR}"/${P}-parallel.patch
- "${FILESDIR}"/${P}-c++14.patch
- )
+PATCHES=(
+ "${FILESDIR}"/${P}-parallel.patch
+ "${FILESDIR}"/${P}-c++14.patch
+ "${FILESDIR}"/${P}-jpeg-9c.patch
+)
src_prepare() {
default