summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2020-05-29 14:30:10 +0300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2020-05-29 14:31:42 +0300
commita466e94e21a5db6bf9c5e459725e26391fa582a1 (patch)
tree8709eda781f72f3aaa19f2a83ad081295c16a4a9 /sci-visualization/gr/gr-0.49.0.ebuild
parentapp-admin/mcelog: 169 stable on amd64 & x86 (diff)
downloadgentoo-a466e94e21a5db6bf9c5e459725e26391fa582a1.tar.gz
gentoo-a466e94e21a5db6bf9c5e459725e26391fa582a1.tar.bz2
gentoo-a466e94e21a5db6bf9c5e459725e26391fa582a1.zip
sci-visualization/gr: New package. Somewhat WIP.
Closes: https://bugs.gentoo.org/683188 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sci-visualization/gr/gr-0.49.0.ebuild')
-rw-r--r--sci-visualization/gr/gr-0.49.0.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/sci-visualization/gr/gr-0.49.0.ebuild b/sci-visualization/gr/gr-0.49.0.ebuild
new file mode 100644
index 000000000000..cf5992490cfb
--- /dev/null
+++ b/sci-visualization/gr/gr-0.49.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Universal framework for cross-platform visualization applications"
+HOMEPAGE="http://gr-framework.org/"
+SRC_URI="https://github.com/sciapp/gr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cairo ffmpeg opengl postscript qt5 tiff truetype X"
+
+DEPEND="
+ media-libs/fontconfig
+ media-libs/libjpeg-turbo
+ media-libs/libpng
+ media-libs/qhull
+ sys-libs/zlib
+ cairo? ( x11-libs/cairo )
+ ffmpeg? ( media-video/ffmpeg )
+ opengl? (
+ media-libs/glfw
+ virtual/opengl
+ )
+ postscript? ( app-text/ghostscript-gpl )
+ qt5? ( dev-qt/qtgui:5 )
+ tiff? ( media-libs/tiff )
+ truetype? ( media-libs/freetype )
+ X? ( x11-libs/libX11 )
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}/${P}-paths.patch"
+)
+
+src_configure() {
+ use cairo || mycmakeargs+=( -DCAIRO_LIBRARY= )
+ use opengl || mycmakeargs+=( -DGLFW_LIBRARY= )
+ use postscript || mycmakeargs+=( -DGS_LIBRARY= )
+ use ffmpeg || mycmakeargs+=( -DFFMPEG_INCLUDE_DIR= )
+ use truetype || mycmakeargs+=( -DFREETYPE_LIBRARY= )
+ use tiff || mycmakeargs+=( -DTIFF_LIBRARY= )
+
+ # todo: Qt5, X11 automagic
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ find "${ED}" -name '*.a' -delete
+}