summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 07:53:42 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:10:14 +0100
commit748305020290e379bb204adbfb00f11a27d1843a (patch)
treea7fefaf995bd6be5c47ac63b8128823941ea177b /sci-visualization/spectromatic
parentsci-mathematics/pari: respect PKG_CONFIG (diff)
downloadgentoo-748305020290e379bb204adbfb00f11a27d1843a.tar.gz
gentoo-748305020290e379bb204adbfb00f11a27d1843a.tar.bz2
gentoo-748305020290e379bb204adbfb00f11a27d1843a.zip
sci-visualization/spectromatic: respect PKG_CONFIG
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-visualization/spectromatic')
-rw-r--r--sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch2
-rw-r--r--sci-visualization/spectromatic/spectromatic-1.0-r3.ebuild5
2 files changed, 3 insertions, 4 deletions
diff --git a/sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch b/sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch
index 619aaecf7a89..ea1fa0a70eec 100644
--- a/sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch
+++ b/sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch
@@ -8,7 +8,7 @@ Fix install paths
-CFLAGS = -O2 -Wall
-LIBS = -lgsl -lgslcblas -lpng -lm
-+LIBS = -lpng `pkg-config --libs gsl`
++LIBS = -lpng `${PKG_CONFIG} --libs gsl`
DESTDIR =
-TOPLEVEL_HOME = /usr
+TOPLEVEL_HOME ?= /usr
diff --git a/sci-visualization/spectromatic/spectromatic-1.0-r3.ebuild b/sci-visualization/spectromatic/spectromatic-1.0-r3.ebuild
index d7bd8aaf7c93..b9337658357c 100644
--- a/sci-visualization/spectromatic/spectromatic-1.0-r3.ebuild
+++ b/sci-visualization/spectromatic/spectromatic-1.0-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,7 +14,6 @@ SRC_URI="http://ieee.uow.edu.au/~daniel/software/spectromatic/dist/${MY_P}.tar.g
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
RDEPEND="
media-libs/libpng:0=
@@ -29,6 +28,6 @@ PATCHES=(
)
src_configure() {
- tc-export CC
+ tc-export CC PKG_CONFIG
export TOPLEVEL_HOME="${EPREFIX}/usr"
}