summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-03-12 19:19:33 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-03-12 19:19:48 +0100
commit08e79aa0349241b7d5e288d6d40d2f2114c4c2df (patch)
tree99a72c5a77a06674bbdb4875d00ba95e5e22367f /sci-visualization
parentapp-text/ghostscript-gpl: add LFS flags (diff)
downloadgentoo-08e79aa0349241b7d5e288d6d40d2f2114c4c2df.tar.gz
gentoo-08e79aa0349241b7d5e288d6d40d2f2114c4c2df.tar.bz2
gentoo-08e79aa0349241b7d5e288d6d40d2f2114c4c2df.zip
sci-visualization/dash: add 2.12.1, drop 2.10.2
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/dash/Manifest3
-rw-r--r--sci-visualization/dash/dash-2.12.1.ebuild (renamed from sci-visualization/dash/dash-2.10.2.ebuild)24
2 files changed, 25 insertions, 2 deletions
diff --git a/sci-visualization/dash/Manifest b/sci-visualization/dash/Manifest
index 8798b0062725..81d028509d11 100644
--- a/sci-visualization/dash/Manifest
+++ b/sci-visualization/dash/Manifest
@@ -1 +1,2 @@
-DIST dash-2.10.2.tar.gz 24196352 BLAKE2B 8e95700756adac363e62d62f0bef6ca1559468f26a79fd8d1595f71ed930cd425cc7a102a32b09611f2def6a0a920772c07d810b598f65c97690f598343b44b4 SHA512 9e7ed9a65d374c32ace75eb9d124b017741ee8de8b115e0323ef4d9f2f6ff7de77bd1f6f083bc92268f29e389c7e2177ab97e5a859afc075be0f546ad820c1ed
+DIST dash-2.12.1.tar.gz 24239780 BLAKE2B bd46dc902555b9877651a3285a35b9ac5cbf2beff327e7689768a1257e0f7982ba3e497cb78c092faf59132702695b87601b585f6d55f4685b27965845aaf3d6 SHA512 88ba2ba078cbddfa0e322ed65afb89f376d0ff8654b34658e1889eca02e12de65ba06493dd01e15fd30e445af0cfe0779931a26e9ac3d88a1400d588036368db
+DIST dash-jupyterlab-2.12.1.tgz 2260 BLAKE2B 4ce19390f58ab74e5a8c8a3926ba6d82db15b603f9123bcb1372bc6919bc5a48ffa0e9c97fa0ca654607a269d125e4e20b2e7e780cea6bb4d70fbed8bda05c75 SHA512 2bede3e1a3469b299bdfa900ca6c75b05c0ecc72d16ed510e8ee2ee0e5538584bedc43ff25cf0ae910ea60b35177fa33219383d8f3ab2cec3a69f0e3f9f7f43c
diff --git a/sci-visualization/dash/dash-2.10.2.ebuild b/sci-visualization/dash/dash-2.12.1.ebuild
index 99937d9520d1..10dc2e7c717a 100644
--- a/sci-visualization/dash/dash-2.10.2.ebuild
+++ b/sci-visualization/dash/dash-2.12.1.ebuild
@@ -10,7 +10,8 @@ inherit distutils-r1
DESCRIPTION="Python framework for building ML & data science web apps"
HOMEPAGE="https://github.com/plotly/dash"
SRC_URI="https://github.com/plotly/${PN}/archive/refs/tags/v${PV}.tar.gz
- -> ${P}.tar.gz"
+ -> ${P}.tar.gz
+ https://dev.gentoo.org/~tupone/distfiles/${PN}-jupyterlab-${PV}.tgz"
LICENSE="MIT"
SLOT="0"
@@ -22,9 +23,30 @@ KEYWORDS="~amd64"
RESTRICT="test"
RDEPEND="
+ dev-python/nest-asyncio[${PYTHON_USEDEP}]
dev-python/plotly[${PYTHON_USEDEP}]
dev-python/flask-compress[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? ( dev-python/beautifulsoup4 )"
distutils_enable_tests pytest
+
+src_unpack() {
+ unpack ${P}.tar.gz
+}
+
+src_prepare() {
+ mkdir dash/labextension/dist || die
+ # cd @plotly/dash-jupyterlab
+ # jlpm install
+ # jlpm build:pack
+ cp "${DISTDIR}"/${PN}-jupyterlab-${PV}.tgz \
+ dash/labextension/dist/${PN}-jupyterlab.tgz \
+ || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ mv "${ED}"/usr/etc "${ED}"/etc || die
+}