summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-03-28 21:31:07 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-03-28 21:32:44 +0200
commit6b07203c63d31ecd1ac1beb61a7229347634dacf (patch)
treec07b81f54a3337d6d08ace92e9738d375635298a /sci-visualization
parentnet-fs/samba: Added dev-perl/JSON to DEPEND (diff)
downloadgentoo-6b07203c63d31ecd1ac1beb61a7229347634dacf.tar.gz
gentoo-6b07203c63d31ecd1ac1beb61a7229347634dacf.tar.bz2
gentoo-6b07203c63d31ecd1ac1beb61a7229347634dacf.zip
sci-visualization/gwyddion: add 2.60
Bug: https://bugs.gentoo.org/598682 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/gwyddion/Manifest1
-rw-r--r--sci-visualization/gwyddion/files/gwyddion-2.60-automagic.patch35
-rw-r--r--sci-visualization/gwyddion/gwyddion-2.60.ebuild83
-rw-r--r--sci-visualization/gwyddion/metadata.xml6
4 files changed, 125 insertions, 0 deletions
diff --git a/sci-visualization/gwyddion/Manifest b/sci-visualization/gwyddion/Manifest
index 1accbe6e79fe..17b49326cbea 100644
--- a/sci-visualization/gwyddion/Manifest
+++ b/sci-visualization/gwyddion/Manifest
@@ -1 +1,2 @@
DIST gwyddion-2.56.tar.xz 4645620 BLAKE2B f4f2ce2bf119a24c3e1919b14db409a81ad286ef2242918f356d2b4c56b498f41cbafa03a136eac5d87b4905529e06982694f19bdf30933454e94d34526962c3 SHA512 cf4a40367ea5b0a671c5df70123ef93f6aecc25322af7eb05e4f32d40e54d9b0d48ddd1df9f2589c468eb511ada3f3ef409603c1513de33ba2482078a9415eae
+DIST gwyddion-2.60.tar.xz 4973404 BLAKE2B 6ded40f34bfcd70db2e897abc1f07b070aca78e08c90661ee4fe281d19f16337ca81b5a4e2adaeb29e1870e8194eb77976910a54248842c8474864065d64defd SHA512 e568df77ef580aaedfcdd1f746a78f3ca93676a07a331fc6e70f997780bb403d1c3967aa93440c7fa1f010bd01f5376700c869a38dacaf1f98b075c4c950cf54
diff --git a/sci-visualization/gwyddion/files/gwyddion-2.60-automagic.patch b/sci-visualization/gwyddion/files/gwyddion-2.60-automagic.patch
new file mode 100644
index 000000000000..ac68ac0a2861
--- /dev/null
+++ b/sci-visualization/gwyddion/files/gwyddion-2.60-automagic.patch
@@ -0,0 +1,35 @@
+diff --git a/configure.ac b/configure.ac
+index 5a7465a..cc5a54d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -660,11 +660,13 @@ AM_CONDITIONAL([HAVE_CXX],[test "x$have_cxx" != xno])
+ #############################################################################
+ # OpenEXR 2.x+
+ # Optional. Used for HDR greyscale OpenEXR pixmap import/export.
+-enable_exr=$have_cxx
+-PKG_CHECK_MODULES(EXR, [OpenEXR >= 2.0],
++GWY_WITH([exr],,[build with OpenEXR support])
++if test "x$enable_exr" != "xno" && "x$have_cxx" != "xno"; then
++ PKG_CHECK_MODULES(EXR, [OpenEXR],
+ [AC_DEFINE(HAVE_EXR,1,
+ [Define if we have the OpenEXR 2.x+ package.])],
+ [enable_exr=no])
++fi
+ AM_CONDITIONAL([HAVE_EXR],[test "x$enable_exr" != xno])
+
+ #############################################################################
+@@ -679,10 +681,13 @@ AM_CONDITIONAL([HAVE_HDF5],[test "x$enable_hdf5" != xno])
+ #############################################################################
+ # CFITSIO
+ # Optional. Used for FITS image import.
+-PKG_CHECK_MODULES(CFITSIO, [cfitsio],
++GWY_WITH([cfitsio],,[build with cfitsio support])
++if test "x$enable_cfitsio" != "xno"; then
++ PKG_CHECK_MODULES(CFITSIO, [cfitsio],
+ [AC_DEFINE(HAVE_CFITSIO,1,
+ [Define if we have the cfitsio package.])],
+ [enable_cfitsio=no])
++fi
+ AM_CONDITIONAL([HAVE_CFITSIO],[test "x$enable_cfitsio" != xno])
+
+ #############################################################################
diff --git a/sci-visualization/gwyddion/gwyddion-2.60.ebuild b/sci-visualization/gwyddion/gwyddion-2.60.ebuild
new file mode 100644
index 000000000000..ff875e5ab41d
--- /dev/null
+++ b/sci-visualization/gwyddion/gwyddion-2.60.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools xdg
+
+DESCRIPTION="Framework for Scanning Mode Microscopy data analysis"
+HOMEPAGE="http://gwyddion.net/"
+SRC_URI="http://gwyddion.net/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 doc fits jansson hdf5 nls openexr openmp perl ruby sourceview unique xml X zlib"
+
+RDEPEND="
+ >=dev-libs/glib-2.32
+ dev-libs/libzip
+ media-libs/libpng:0=
+ >=sci-libs/fftw-3.1:3.0=[openmp?]
+ virtual/libiconv
+ virtual/libintl
+ x11-libs/cairo
+ >=x11-libs/gtk+-2.18:2
+ x11-libs/libXmu
+ x11-libs/pango
+ bzip2? ( app-arch/bzip2 )
+ fits? ( sci-libs/cfitsio[bzip2?] )
+ jansson? ( dev-libs/jansson )
+ hdf5? ( sci-libs/hdf5[zlib?] )
+ openexr? ( media-libs/openexr:= )
+ perl? ( dev-lang/perl:= )
+ ruby? ( dev-ruby/narray )
+ unique? ( dev-libs/libunique:3 )
+ sourceview? ( x11-libs/gtksourceview:2.0 )
+ xml? ( dev-libs/libxml2:2 )
+ zlib? ( sys-libs/zlib )
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.60-automagic.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+# There are python bindings (--enable-pygwy) but they are py2 only
+# 3D opengl rendering requires deprecated GTK-2 x11-libs/gtkglext
+src_configure() {
+ # hack for bug 741840
+ use doc && export GTK_DOC_PATH=/usr/share/gtk-doc
+
+ econf \
+ --disable-rpath \
+ --without-kde4-thumbnailer \
+ $(use_enable doc gtk-doc) \
+ $(use_enable openmp) \
+ $(use_enable nls) \
+ --disable-pygwy \
+ --without-python \
+ $(use_with bzip2) \
+ $(use_with fits cfitsio) \
+ $(use_with hdf5) \
+ $(use_with perl) \
+ $(use_with ruby) \
+ $(use_with openexr exr) \
+ --without-gl \
+ $(use_with sourceview gtksourceview) \
+ $(use_with unique) \
+ $(use_with xml libxml2) \
+ $(use_with X x) \
+ $(use_with zlib) \
+ --with-zip=libzip
+}
diff --git a/sci-visualization/gwyddion/metadata.xml b/sci-visualization/gwyddion/metadata.xml
index 7749445d7975..7259dfaa2d64 100644
--- a/sci-visualization/gwyddion/metadata.xml
+++ b/sci-visualization/gwyddion/metadata.xml
@@ -23,5 +23,11 @@
<flag name="fits">
Enable FITS image import via <pkg>sci-libs/cfitsio</pkg>
</flag>
+ <flag name="jansson">
+ Enable JSON data manipulation via <pkg>dev-libs/jansson</pkg>
+ </flag>
+ <flag name="unique">
+ Enable remote control backend via <pkg>dev-libs/libunique</pkg>
+ </flag>
</use>
</pkgmetadata>