summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-17 23:14:59 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-18 23:32:38 +0100
commit3797956224f41ed5128ce4f8fd68f15d9757f8dc (patch)
tree9e6787532d3141c3c6e2466b03a35ef3f5deb2ce /sec-keys
parentMove {app-crypt → sec-keys}/openpgp-keys-django (diff)
downloadgentoo-3797956224f41ed5128ce4f8fd68f15d9757f8dc.tar.gz
gentoo-3797956224f41ed5128ce4f8fd68f15d9757f8dc.tar.bz2
gentoo-3797956224f41ed5128ce4f8fd68f15d9757f8dc.zip
Move {app-crypt → sec-keys}/openpgp-keys-gentoo-auth
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sec-keys')
-rw-r--r--sec-keys/openpgp-keys-gentoo-auth/Manifest1
-rw-r--r--sec-keys/openpgp-keys-gentoo-auth/metadata.xml9
-rw-r--r--sec-keys/openpgp-keys-gentoo-auth/openpgp-keys-gentoo-auth-20200704.ebuild27
3 files changed, 37 insertions, 0 deletions
diff --git a/sec-keys/openpgp-keys-gentoo-auth/Manifest b/sec-keys/openpgp-keys-gentoo-auth/Manifest
new file mode 100644
index 000000000000..928b9645b900
--- /dev/null
+++ b/sec-keys/openpgp-keys-gentoo-auth/Manifest
@@ -0,0 +1 @@
+DIST gentoo-auth.asc.20200704.gz 4540 BLAKE2B 8ae8a1947ae81e89aef6171b228e97a80331cc58336a0387bbda7c885ec5fff322d17b7fc462d7f3fe88a965455b94d1e16b705903843d75fa53481d525a1965 SHA512 da7d1aa76ea04f465e690560dd2d09306aa120b9f2771abc6fe06d5181c39c9e7db73ae0b9c01b864ccdd55a881a7e9c9716dd87446c809b901bb17c448878f5
diff --git a/sec-keys/openpgp-keys-gentoo-auth/metadata.xml b/sec-keys/openpgp-keys-gentoo-auth/metadata.xml
new file mode 100644
index 000000000000..996eb9fa78a2
--- /dev/null
+++ b/sec-keys/openpgp-keys-gentoo-auth/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <stabilize-allarches/>
+</pkgmetadata>
diff --git a/sec-keys/openpgp-keys-gentoo-auth/openpgp-keys-gentoo-auth-20200704.ebuild b/sec-keys/openpgp-keys-gentoo-auth/openpgp-keys-gentoo-auth-20200704.ebuild
new file mode 100644
index 000000000000..07b5242d0799
--- /dev/null
+++ b/sec-keys/openpgp-keys-gentoo-auth/openpgp-keys-gentoo-auth-20200704.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Gentoo Authority Keys (GLEP 79)"
+HOMEPAGE="https://www.gentoo.org/downloads/signatures/"
+SRC_URI="https://dev.gentoo.org/~mgorny/dist/openpgp-keys/gentoo-auth.asc.${PV}.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+S=${WORKDIR}
+
+# Keys included:
+# ABD00913019D6354BA1D9A132839FE0D796198B1
+# 18F703D702B1B9591373148C55D3238EC050396E
+# 2C13823B8237310FA213034930D132FF0FF50EEB
+
+src_install() {
+ insinto /usr/share/openpgp-keys
+ newins "gentoo-auth.asc.${PV}" gentoo-auth.asc
+ newins - gentoo-auth-ownertrust.txt <<-EOF
+ ABD00913019D6354BA1D9A132839FE0D796198B1:6:
+ EOF
+}