summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2020-11-29 13:59:01 -0800
committerJason Zaman <perfinion@gentoo.org>2020-11-29 20:08:18 -0800
commit942ac83f3aae1c7a8ab49aa62d3fb19ae0ab5df5 (patch)
treead0c62b7db7392a1cf6d12484c82324ee8fde7c4 /sec-policy/selinux-base-policy
parentdev-db/pgbadger: Bump to 11.4 (diff)
downloadgentoo-942ac83f3aae1c7a8ab49aa62d3fb19ae0ab5df5.tar.gz
gentoo-942ac83f3aae1c7a8ab49aa62d3fb19ae0ab5df5.tar.bz2
gentoo-942ac83f3aae1c7a8ab49aa62d3fb19ae0ab5df5.zip
sec-policy: Update selinux 9999 packages to EAPI7
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sec-policy/selinux-base-policy')
-rw-r--r--sec-policy/selinux-base-policy/selinux-base-policy-9999.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/sec-policy/selinux-base-policy/selinux-base-policy-9999.ebuild b/sec-policy/selinux-base-policy/selinux-base-policy-9999.ebuild
index 17908940fcb0..5de9dfd5ff41 100644
--- a/sec-policy/selinux-base-policy/selinux-base-policy-9999.ebuild
+++ b/sec-policy/selinux-base-policy/selinux-base-policy-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="${SELINUX_GIT_REPO:-https://anongit.gentoo.org/git/proj/hardened-refpolicy.git}"
@@ -23,6 +23,9 @@ IUSE="systemd +unconfined"
PDEPEND="unconfined? ( sec-policy/selinux-unconfined )"
DEPEND="=sec-policy/selinux-base-${PVR}[systemd?]"
RDEPEND="$DEPEND"
+BDEPEND="
+ sys-apps/checkpolicy
+ sys-devel/m4"
MODS="application authlogin bootloader clock consoletype cron dmesg fstools getty hostname hotplug init iptables libraries locallogin logging lvm miscfiles modutils mount mta netutils nscd portage raid rsync selinuxutil setrans ssh staff storage su sysadm sysnetwork systemd tmpfiles udev userdomain usermanage unprivuser xdg"
LICENSE="GPL-2"
@@ -69,7 +72,7 @@ src_prepare() {
src_compile() {
for i in ${POLICY_TYPES}; do
- emake NAME=$i SHAREDIR="${ROOT%/}"/usr/share/selinux -C "${S}"/${i}
+ emake NAME=$i SHAREDIR="${ROOT}"/usr/share/selinux -C "${S}"/${i}
done
}
@@ -88,8 +91,8 @@ src_install() {
pkg_postinst() {
# Set root path and don't load policy into the kernel when cross compiling
local root_opts=""
- if [[ "${ROOT%/}" != "" ]]; then
- root_opts="-p ${ROOT%/} -n"
+ if [[ "${ROOT}" != "" ]]; then
+ root_opts="-p ${ROOT} -n"
fi
# Override the command from the eclass, we need to load in base as well here
@@ -105,13 +108,13 @@ pkg_postinst() {
for i in ${POLICY_TYPES}; do
einfo "Inserting the following modules, with base, into the $i module store: ${MODS}"
- cd "${ROOT%/}/usr/share/selinux/${i}"
+ cd "${ROOT}/usr/share/selinux/${i}"
semodule ${root_opts} -s ${i} ${COMMAND}
done
# Don't relabel when cross compiling
- if [[ "${ROOT%/}" == "" ]]; then
+ if [[ "${ROOT}" == "" ]]; then
# Relabel depending packages
local PKGSET="";
if [[ -x /usr/bin/qdepends ]] ; then