summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2020-11-29 13:59:01 -0800
committerJason Zaman <perfinion@gentoo.org>2020-11-29 20:08:18 -0800
commit942ac83f3aae1c7a8ab49aa62d3fb19ae0ab5df5 (patch)
treead0c62b7db7392a1cf6d12484c82324ee8fde7c4 /sec-policy/selinux-base
parentdev-db/pgbadger: Bump to 11.4 (diff)
downloadgentoo-942ac83f3aae1c7a8ab49aa62d3fb19ae0ab5df5.tar.gz
gentoo-942ac83f3aae1c7a8ab49aa62d3fb19ae0ab5df5.tar.bz2
gentoo-942ac83f3aae1c7a8ab49aa62d3fb19ae0ab5df5.zip
sec-policy: Update selinux 9999 packages to EAPI7
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sec-policy/selinux-base')
-rw-r--r--sec-policy/selinux-base/selinux-base-9999.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/sec-policy/selinux-base/selinux-base-9999.ebuild b/sec-policy/selinux-base/selinux-base-9999.ebuild
index a16000f98026..3be921e88deb 100644
--- a/sec-policy/selinux-base/selinux-base-9999.ebuild
+++ b/sec-policy/selinux-base/selinux-base-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="${SELINUX_GIT_REPO:-https://anongit.gentoo.org/git/proj/hardened-refpolicy.git}"
@@ -24,9 +24,10 @@ LICENSE="GPL-2"
SLOT="0"
RDEPEND=">=sys-apps/policycoreutils-2.8"
-DEPEND="${RDEPEND}
- sys-devel/m4
- >=sys-apps/checkpolicy-2.8"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=sys-apps/checkpolicy-2.8
+ sys-devel/m4"
S=${WORKDIR}/
@@ -46,7 +47,6 @@ src_configure() {
[ -z "${POLICY_TYPES}" ] && local POLICY_TYPES="targeted strict mls mcs"
# Update the SELinux refpolicy capabilities based on the users' USE flags.
-
if use unknown-perms; then
sed -i -e '/^UNK_PERMS/s/deny/allow/' "${S}/refpolicy/build.conf" \
|| die "Failed to allow Unknown Permissions Handling"
@@ -76,7 +76,6 @@ src_configure() {
cp -a "${S}/refpolicy" "${S}/${i}" || die
cd "${S}/${i}" || die
- #cp "${FILESDIR}/modules-2.20120215.conf" "${S}/${i}/policy/modules.conf"
sed -i -e "/= module/d" "${S}/${i}/policy/modules.conf" || die
sed -i -e '/^QUIET/s/n/y/' -e "/^NAME/s/refpolicy/$i/" \