summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-11 10:12:09 +0100
committerSam James <sam@gentoo.org>2022-08-11 10:42:01 +0100
commitf4c63f562ab9e74c363af1cedc93d9f64a6a0b40 (patch)
tree18575f330f82f14a05eb8e7495d5a1bb924d2a88 /sys-apps/accountsservice
parentdev-python/podman-py: Bump to 4.2.0 (diff)
downloadgentoo-f4c63f562ab9e74c363af1cedc93d9f64a6a0b40.tar.gz
gentoo-f4c63f562ab9e74c363af1cedc93d9f64a6a0b40.tar.bz2
gentoo-f4c63f562ab9e74c363af1cedc93d9f64a6a0b40.zip
sys-apps/accountsservice: fix PythonAnyMismatchedDepHasVersionCheck
has_version was checking DEPEND, not BDEPEND, so change to python_has_version for better defaults (defaults to BDEPEND) but also nicer output. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/accountsservice')
-rw-r--r--sys-apps/accountsservice/accountsservice-22.08.8.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/sys-apps/accountsservice/accountsservice-22.08.8.ebuild b/sys-apps/accountsservice/accountsservice-22.08.8.ebuild
index a989b367b5f4..40e0dad498bc 100644
--- a/sys-apps/accountsservice/accountsservice-22.08.8.ebuild
+++ b/sys-apps/accountsservice/accountsservice-22.08.8.ebuild
@@ -55,7 +55,7 @@ PATCHES=(
python_check_deps() {
if use test; then
- has_version "dev-python/python-dbusmock[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/python-dbusmock[${PYTHON_USEDEP}]"
fi
}