summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/adjtime/adjtime-0.4-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/adjtime/adjtime-0.4-r2.ebuild')
-rw-r--r--sys-apps/adjtime/adjtime-0.4-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/adjtime/adjtime-0.4-r2.ebuild b/sys-apps/adjtime/adjtime-0.4-r2.ebuild
new file mode 100644
index 000000000000..a723741cb411
--- /dev/null
+++ b/sys-apps/adjtime/adjtime-0.4-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A perl script to adjust the clock tick of the hardware clock on the system board"
+HOMEPAGE="http://groups.yahoo.com/group/LinkStation_General/"
+SRC_URI="http://www.gentoogeek.org/files/${PN}.zip"
+
+LICENSE="all-rights-reserved" #441922
+SLOT="0"
+KEYWORDS="ppc"
+RESTRICT="mirror bindist"
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-lang/perl
+ >=net-misc/ntp-4.2"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ sed -i -e 's:/usr/sbin/tickadj:/usr/bin/tickadj:' adjtime.pl || die
+}
+
+src_install() {
+ dosbin adjtime.pl
+}
+
+pkg_postinst() {
+ ewarn "There have been issues with running adjtime as an init script"
+ ewarn "(the shell environment for perl is dorked up). The suggested"
+ ewarn "method is to use ntp-date rather than ntpd at startup, and"
+ ewarn "add the following two lines to local.start instead:"
+ ewarn
+ ewarn "/usr/bin/perl /usr/sbin/adjtime.pl -v -s ntp_host -i 60"
+ ewarn
+ ewarn "/etc/init.d/ntpd start"
+ ewarn
+ ewarn "replacing ntp_host with your preferred ntp server. Remember,"
+ ewarn "since adjtime uses ntp-date, ntpd must be stopped (or not yet"
+ ewarn "started) prior to running the adjtime script."
+}