summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-07-02 13:40:52 -0400
committerAnthony G. Basile <blueness@gentoo.org>2019-07-02 13:40:52 -0400
commit62ccbfb039074dd1320889d30d5792231cbcf78e (patch)
tree78d5ec336b025186bcbcdbc8805358fe45d518a4 /sys-apps/agedu/agedu-20190630.ebuild
parentmedia-libs/x265: bump to 3.1 (diff)
downloadgentoo-62ccbfb039074dd1320889d30d5792231cbcf78e.tar.gz
gentoo-62ccbfb039074dd1320889d30d5792231cbcf78e.tar.bz2
gentoo-62ccbfb039074dd1320889d30d5792231cbcf78e.zip
sys-apps/agedu: version bump to 20190630
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'sys-apps/agedu/agedu-20190630.ebuild')
-rw-r--r--sys-apps/agedu/agedu-20190630.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/agedu/agedu-20190630.ebuild b/sys-apps/agedu/agedu-20190630.ebuild
new file mode 100644
index 000000000000..2b4da5780461
--- /dev/null
+++ b/sys-apps/agedu/agedu-20190630.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools eutils
+
+# agedu-20151213.59b0ed3.ebuild is not a legitimate name
+# so we'll drop versionator and just set MY_P manually.
+MY_P="${PN}"-20190630.66cb14d
+
+DESCRIPTION="A utility for tracking down wasted disk space"
+HOMEPAGE="https://www.chiark.greenend.org.uk/~sgtatham/agedu/"
+SRC_URI="https://www.chiark.greenend.org.uk/~sgtatham/agedu/${MY_P}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc ipv6"
+
+DEPEND="doc? ( app-doc/halibut )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-r9671-fix-automagic.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-ipv4 \
+ $(use_enable doc halibut) \
+ $(use_enable ipv6)
+}