summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-11-13 16:17:34 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2018-11-16 18:13:17 +0100
commit71022330c7696ed94cbb6b5af48f36a56bf3a066 (patch)
tree995eee42e902e0afe9b9d4ff1f129e2ee46787e5 /sys-apps/bubblewrap
parentsys-cluster/openmpi: bump 3.1.3 (diff)
downloadgentoo-71022330c7696ed94cbb6b5af48f36a56bf3a066.tar.gz
gentoo-71022330c7696ed94cbb6b5af48f36a56bf3a066.tar.bz2
gentoo-71022330c7696ed94cbb6b5af48f36a56bf3a066.zip
sys-apps/bubblewrap: reviewed ebuild
Fix R/DEPEND. Add support for setuid and make it default per bug #669210. Use release tarballs. Fix bash-completion eclass call. Closes: https://bugs.gentoo.org/669210 Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'sys-apps/bubblewrap')
-rw-r--r--sys-apps/bubblewrap/Manifest1
-rw-r--r--sys-apps/bubblewrap/bubblewrap-0.3.1-r1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/sys-apps/bubblewrap/Manifest b/sys-apps/bubblewrap/Manifest
index dba0bcb214e6..9abc9af835b4 100644
--- a/sys-apps/bubblewrap/Manifest
+++ b/sys-apps/bubblewrap/Manifest
@@ -1 +1,2 @@
DIST bubblewrap-0.3.1.tar.gz 62768 BLAKE2B a8c29102f9b69bfbd6b6aebb9aa0878bd1e31b52a6cb6374b8341c1410526872d4063ff0524ab4f98d7cac7358dad3190144d12bb0b11cf26eeed2730c4ec475 SHA512 fbc44976f53fdf8913b94c57d1f26a3b87c773e86a289e58fd3d7b1c4ea7f33c862f1a38a4f791315358990928768a68334f0a171302c18a16c7e2e9f1a146dd
+DIST bubblewrap-0.3.1.tar.xz 209924 BLAKE2B bacc4080106cd9876bf0e1ad866a7397d7d232e61a720b52b5a6b9b0d860e625511ed15ac630aa71003fb9fa145ffa9d08ae2e6ba6d1411fd75e7d9568312717 SHA512 74e36caa56540a956158445f5f38c7ac5f7ff3c733ecaf85893de4607900e1fe4050db86a4435cbe18d722e90c5b39c466c555ea8ea8d4944da6207ef1011d67
diff --git a/sys-apps/bubblewrap/bubblewrap-0.3.1-r1.ebuild b/sys-apps/bubblewrap/bubblewrap-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..39a0a3e1e08c
--- /dev/null
+++ b/sys-apps/bubblewrap/bubblewrap-0.3.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 linux-info
+
+DESCRIPTION="Unprivileged sandboxing tool, namespaces-powered chroot-like solution"
+HOMEPAGE="https://github.com/projectatomic/bubblewrap"
+SRC_URI="https://github.com/projectatomic/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="selinux +suid"
+
+RDEPEND="
+ sys-libs/libseccomp
+ sys-libs/libcap
+ selinux? ( >=sys-libs/libselinux-2.1.9 )
+"
+DEPEND="${DEPEND}
+ app-text/docbook-xml-dtd:4.3
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+
+# tests require root priviledge
+RESTRICT="test"
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != buildonly ]]; then
+ CONFIG_CHECK="~UTS_NS ~IPC_NS ~USER_NS ~PID_NS ~NET_NS"
+ linux-info_pkg_setup
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable selinux) \
+ "--enable-man" \
+ "--with-bash-completion-dir=$(get_bashcompdir)" \
+ "--with-priv-mode=$(usex suid setuid none)"
+}