summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2020-12-21 18:49:58 -0500
committerJason Zaman <perfinion@gentoo.org>2021-01-03 00:19:48 -0800
commitf3c39033c18a29a9a5ee4ba8caaf1fb299fd3dd3 (patch)
treed94ef51a79cbdf1c21c8eaecb502cdd73b29325f /sys-apps/checkpolicy
parentapp-admin/setools: move cython to BDEPEND (diff)
downloadgentoo-f3c39033c18a29a9a5ee4ba8caaf1fb299fd3dd3.tar.gz
gentoo-f3c39033c18a29a9a5ee4ba8caaf1fb299fd3dd3.tar.bz2
gentoo-f3c39033c18a29a9a5ee4ba8caaf1fb299fd3dd3.zip
sys-apps/checkpolicy: move flex and bison to BDEPEND
Also remove the libsemanage dependency since it is not referenced by the code. Links against the libsepol static library but leave in RDEPEND too. Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-apps/checkpolicy')
-rw-r--r--sys-apps/checkpolicy/checkpolicy-3.1.ebuild12
-rw-r--r--sys-apps/checkpolicy/checkpolicy-9999.ebuild12
2 files changed, 10 insertions, 14 deletions
diff --git a/sys-apps/checkpolicy/checkpolicy-3.1.ebuild b/sys-apps/checkpolicy/checkpolicy-3.1.ebuild
index 070a1f1418cc..1b8381709ac8 100644
--- a/sys-apps/checkpolicy/checkpolicy-3.1.ebuild
+++ b/sys-apps/checkpolicy/checkpolicy-3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -28,12 +28,11 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="debug"
-DEPEND=">=sys-libs/libsepol-${SEPOL_VER}
- >=sys-libs/libsemanage-${SEMNG_VER}
- sys-devel/flex
+DEPEND=">=sys-libs/libsepol-${SEPOL_VER}"
+BDEPEND="sys-devel/flex
sys-devel/bison"
-RDEPEND=">=sys-libs/libsemanage-${SEMNG_VER}"
+RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}"
src_compile() {
emake \
@@ -43,8 +42,7 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" \
- install
+ default
if use debug; then
dobin "${S}/test/dismod"
diff --git a/sys-apps/checkpolicy/checkpolicy-9999.ebuild b/sys-apps/checkpolicy/checkpolicy-9999.ebuild
index fe88e2f1c073..90907ec9a0d2 100644
--- a/sys-apps/checkpolicy/checkpolicy-9999.ebuild
+++ b/sys-apps/checkpolicy/checkpolicy-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -28,12 +28,11 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="debug"
-DEPEND=">=sys-libs/libsepol-${SEPOL_VER}
- >=sys-libs/libsemanage-${SEMNG_VER}
- sys-devel/flex
+DEPEND=">=sys-libs/libsepol-${SEPOL_VER}"
+BDEPEND="sys-devel/flex
sys-devel/bison"
-RDEPEND=">=sys-libs/libsemanage-${SEMNG_VER}"
+RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}"
src_compile() {
emake \
@@ -43,8 +42,7 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" \
- install
+ default
if use debug; then
dobin "${S}/test/dismod"