summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/cpint/files/cpint-2.5.3-build.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/cpint/files/cpint-2.5.3-build.patch')
-rw-r--r--sys-apps/cpint/files/cpint-2.5.3-build.patch73
1 files changed, 73 insertions, 0 deletions
diff --git a/sys-apps/cpint/files/cpint-2.5.3-build.patch b/sys-apps/cpint/files/cpint-2.5.3-build.patch
new file mode 100644
index 000000000000..9dacbdb6c7ad
--- /dev/null
+++ b/sys-apps/cpint/files/cpint-2.5.3-build.patch
@@ -0,0 +1,73 @@
+--- cpint-2.5.3/Makefile
++++ cpint-2.5.3/Makefile
+@@ -5,59 +5,29 @@
+ prefix =
+ bindir = /usr/sbin
+ etcdir = /etc
++krndir = /lib/modules/`uname -r`/misc
+
+-COMMAND = hcp mongen monstat actgen diag0
+-
+-tools: $(COMMAND)
++CFLAGS += -Wall
++CPPFLAGS += -I$(KERNEL_DIR)/include
+
+-hcp : hcp.o
+- $(CC) -o $@ $^
++COMMAND = hcp mongen monstat actgen diag0
+
+-hcptest : hcptest.o
+- $(CC) -o $@ $^
++all: $(COMMAND) cpint_mod.ko
+
+-mongen : mongen.o
+- $(CC) -o $@ $^
++cpint_mod.ko:
++ $(MAKE) -C $(KERNEL_DIR) modules SUBDIRS=$(PWD)
+
+-actgen : actgen.o
+- $(CC) -o $@ $^
++tools: $(COMMAND)
+
+ monstat : monstat.o sysinfo.o
+- $(CC) -o $@ $^
+-
+-diag0 : diag0.o
+- $(CC) -o $@ $^
+-
+-hcp.o : hcp.c
+- $(CC) -o $@ $(INCLUDEDIR) -I. -O2 -c hcp.c
+-
+-hcptest.o : hcptest.c
+- $(CC) -o $@ $(INCLUDEDIR) -I. -O2 -c hcptest.c
+-
+-mongen.o : mongen.c
+- $(CC) -o $@ $(INCLUDEDIR) -I. -O2 -c mongen.c
+-
+-monstat.o : monstat.c
+- $(CC) -o $@ $(INCLUDEDIR) -I. -O2 -c monstat.c
+-
+-sysinfo.o : sysinfo.c
+- $(CC) -o $@ $(INCLUDEDIR) -I. -O2 -c sysinfo.c
+-
+-actgen.o : actgen.c
+- $(CC) -o $@ $(INCLUDEDIR) -I. -O2 -c actgen.c
+-
+-diag0.o : diag0.c
+- $(CC) -o $@ $(INCLUDEDIR) -I. -O2 -c diag0.c
+
+ install: $(TARGET)
++ install -d -m 755 ${prefix}${bindir}
+ install -c -m 750 mongen ${prefix}${bindir}
+ install -c -m 750 monstat ${prefix}${bindir}
+ install -c -m 750 hcp ${prefix}${bindir}
+- cp cpint_mod.ko /lib/modules/`uname -r`/kernel/drivers/s390/char/
+- rm -rf /dev/cpcmd /dev/cpmod /dev/cpappl /dev/cpid \
+- /dev/cpint0 /dev/cpint8 /dev/cpint76 /dev/cpint222
+- modprobe -qr cpint_mod
+- depmod -a
++ install -d -m 755 ${prefix}${krndir}
++ install -c -m 644 cpint_mod.ko ${prefix}${krndir}
+
+ clean:
+ rm -rf *.o *~ core mongen monstat actgen hcp diag0 *.ko *.cmd \