summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-08-21 00:54:19 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-08-21 01:29:13 +0200
commit4f277ad2f52551ca8f2e5d37f53c51dcebbb62f6 (patch)
treef27a0301c54c29cba38638569ee3c6a2cd0ebb35 /sys-apps/cpuid
parentdev-libs/libmodbus: add 3.1.8 (diff)
downloadgentoo-4f277ad2f52551ca8f2e5d37f53c51dcebbb62f6.tar.gz
gentoo-4f277ad2f52551ca8f2e5d37f53c51dcebbb62f6.tar.bz2
gentoo-4f277ad2f52551ca8f2e5d37f53c51dcebbb62f6.zip
sys-apps/cpuid: add 20220812
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps/cpuid')
-rw-r--r--sys-apps/cpuid/Manifest1
-rw-r--r--sys-apps/cpuid/cpuid-20220812.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/cpuid/Manifest b/sys-apps/cpuid/Manifest
index 86fd2a311a99..1a58c8bfcc94 100644
--- a/sys-apps/cpuid/Manifest
+++ b/sys-apps/cpuid/Manifest
@@ -1 +1,2 @@
DIST cpuid-20220620.src.tar.gz 134487 BLAKE2B 37beeeef5bbeed47d762f093a568e18ac06b32b4c8c4d763656c5310c78b949c60aaf4e874b15485af15be1e31c389692a0ab277a95a0dcb0b66a7dbece50a52 SHA512 e06db43fb12efa1d112267993754965b8a2b07c914766a46a0fe6fdcf023606cfb132eac575726ad9ed7d0e6fc53d728a6d3d3d7abf2f484f002825c791da7b9
+DIST cpuid-20220812.src.tar.gz 137109 BLAKE2B 158f152d55b0d8f8ca2df59fc19b9f91142296ef4657b6b2b39ca401abfb26db822be7eadb3a4010847483e75aa213b64756dec6cc625db8c96c8fe8e2a8c468 SHA512 f57c1bb78bad3a9a0d210d5da2a57ea6ffeca83c677f20423dc11af551684ba417b8e5641559cf1d5077567937bd2b2350f232e317ff7be388727983be2c1f6a
diff --git a/sys-apps/cpuid/cpuid-20220812.ebuild b/sys-apps/cpuid/cpuid-20220812.ebuild
new file mode 100644
index 000000000000..0f77190b474c
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20220812.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux tool to dump x86 CPUID information about the CPUs"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+BDEPEND="
+ app-arch/gzip
+ dev-lang/perl
+"
+
+DOCS=( "ChangeLog" "FUTURE" )
+
+PATCHES=( "${FILESDIR}/${PN}-20220620-makefile.patch" )
+
+src_prepare() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ emake BUILDROOT="${ED}" install
+
+ einstalldocs
+}