summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-10-02 01:17:56 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-10-02 01:17:56 +0200
commitd60a00610dcab44f9ba2d3f80badb07c173a761a (patch)
tree0b9c1b70efb0008e56d8fa0feba3b1f44534bf56 /sys-apps/cpuid
parentdev-libs/intel-vc-intrinsics: add 0.7.1 (diff)
downloadgentoo-d60a00610dcab44f9ba2d3f80badb07c173a761a.tar.gz
gentoo-d60a00610dcab44f9ba2d3f80badb07c173a761a.tar.bz2
gentoo-d60a00610dcab44f9ba2d3f80badb07c173a761a.zip
sys-apps/cpuid: add 20220927
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps/cpuid')
-rw-r--r--sys-apps/cpuid/Manifest1
-rw-r--r--sys-apps/cpuid/cpuid-20220927.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/cpuid/Manifest b/sys-apps/cpuid/Manifest
index d19ce65d2cab..dff181b173d1 100644
--- a/sys-apps/cpuid/Manifest
+++ b/sys-apps/cpuid/Manifest
@@ -1 +1,2 @@
DIST cpuid-20220812.src.tar.gz 137109 BLAKE2B 158f152d55b0d8f8ca2df59fc19b9f91142296ef4657b6b2b39ca401abfb26db822be7eadb3a4010847483e75aa213b64756dec6cc625db8c96c8fe8e2a8c468 SHA512 f57c1bb78bad3a9a0d210d5da2a57ea6ffeca83c677f20423dc11af551684ba417b8e5641559cf1d5077567937bd2b2350f232e317ff7be388727983be2c1f6a
+DIST cpuid-20220927.src.tar.gz 137355 BLAKE2B 70c51273fb87fe86a4bf1ddef938275474ad3af496cfdbc8e1b8e7dcf3f33b478340fcd3c8c49c6a0d2fe4927e399977e9c53cab118da0098eae2cc83cea51fc SHA512 f621c4cf8cbe027133442aa29018b9b52eb4d0e45a362cf613fee772456ac9e3347582c2feacb6d3358602f6da6425fcd88924e1ba937c89a5eaac43b1f9143f
diff --git a/sys-apps/cpuid/cpuid-20220927.ebuild b/sys-apps/cpuid/cpuid-20220927.ebuild
new file mode 100644
index 000000000000..0f77190b474c
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20220927.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux tool to dump x86 CPUID information about the CPUs"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+BDEPEND="
+ app-arch/gzip
+ dev-lang/perl
+"
+
+DOCS=( "ChangeLog" "FUTURE" )
+
+PATCHES=( "${FILESDIR}/${PN}-20220620-makefile.patch" )
+
+src_prepare() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ emake BUILDROOT="${ED}" install
+
+ einstalldocs
+}