summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-22 00:02:53 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-22 00:53:33 +0100
commit504ec9e306b7226f0fb0c709b429ebf16632a6c2 (patch)
tree7cedd466b615233c8e307ae4a3956601623bd848 /sys-apps/dbus
parentmedia-sound/teamspeak-client: add blocker against qt-5.12 (diff)
downloadgentoo-504ec9e306b7226f0fb0c709b429ebf16632a6c2.tar.gz
gentoo-504ec9e306b7226f0fb0c709b429ebf16632a6c2.tar.bz2
gentoo-504ec9e306b7226f0fb0c709b429ebf16632a6c2.zip
sys-apps/dbus: Fix build w/o dev-libs/expat (non-native ABI)
Closes: https://bugs.gentoo.org/653136 Closes: https://github.com/gentoo/gentoo/pull/11134 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-apps/dbus')
-rw-r--r--sys-apps/dbus/dbus-1.12.12-r1.ebuild281
-rw-r--r--sys-apps/dbus/files/dbus-daemon-optional.patch75
2 files changed, 356 insertions, 0 deletions
diff --git a/sys-apps/dbus/dbus-1.12.12-r1.ebuild b/sys-apps/dbus/dbus-1.12.12-r1.ebuild
new file mode 100644
index 000000000000..59c8de33e336
--- /dev/null
+++ b/sys-apps/dbus/dbus-1.12.12-r1.ebuild
@@ -0,0 +1,281 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+inherit autotools flag-o-matic linux-info python-any-r1 readme.gentoo-r1 systemd virtualx user multilib-minimal
+
+DESCRIPTION="A message bus system, a simple way for applications to talk to each other"
+HOMEPAGE="https://dbus.freedesktop.org/"
+SRC_URI="https://dbus.freedesktop.org/releases/dbus/${P}.tar.gz"
+
+LICENSE="|| ( AFL-2.1 GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug doc elogind selinux static-libs systemd test user-session X"
+
+REQUIRED_USE="?? ( elogind systemd )"
+
+# autoconf-archive-2019.01.06 blocker added for bug #674830
+# Please check on bumps if the blocker is still necessary.
+BDEPEND="
+ app-text/xmlto
+ app-text/docbook-xml-dtd:4.4
+ <sys-devel/autoconf-archive-2019.01.06
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+COMMON_DEPEND="
+ >=dev-libs/expat-2.1.0
+ elogind? ( sys-auth/elogind )
+ selinux? ( sys-libs/libselinux )
+ systemd? ( sys-apps/systemd:0= )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXt
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/expat
+ test? (
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.40:2
+ )
+"
+RDEPEND="${COMMON_DEPEND}
+ selinux? ( sec-policy/selinux-dbus )
+"
+
+DOC_CONTENTS="
+ Some applications require a session bus in addition to the system
+ bus. Please see \`man dbus-launch\` for more information.
+"
+
+# out of sources build dir for make check
+TBD="${WORKDIR}/${P}-tests-build"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-enable-elogind.patch"
+ "${FILESDIR}/${PN}-daemon-optional.patch"
+)
+
+pkg_setup() {
+ enewgroup messagebus
+ enewuser messagebus -1 -1 -1 messagebus
+
+ use test && python-any-r1_pkg_setup
+
+ if use kernel_linux; then
+ CONFIG_CHECK="~EPOLL"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # Tests were restricted because of this
+ sed -i \
+ -e 's/.*bus_dispatch_test.*/printf ("Disabled due to excess noise\\n");/' \
+ -e '/"dispatch"/d' \
+ bus/test-main.c || die
+
+ default
+
+ if [[ ${CHOST} == *-solaris* ]]; then
+ # fix standards conflict, due to gcc being c99 by default nowadays
+ sed -i \
+ -e 's/_XOPEN_SOURCE=500/_XOPEN_SOURCE=600/' \
+ configure.ac || die
+ fi
+
+ # required for bug 263909, cross-compile so don't remove eautoreconf
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local docconf myconf testconf
+
+ # so we can get backtraces from apps
+ case ${CHOST} in
+ *-mingw*)
+ # error: unrecognized command line option '-rdynamic' wrt #488036
+ ;;
+ *)
+ append-flags -rdynamic
+ ;;
+ esac
+
+ # libaudit is *only* used in DBus wrt SELinux support, so disable it, if
+ # not on an SELinux profile.
+ myconf=(
+ --localstatedir="${EPREFIX}/var"
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ $(use_enable static-libs static)
+ $(use_enable debug verbose-mode)
+ --disable-asserts
+ --disable-checks
+ $(use_enable selinux)
+ $(use_enable selinux libaudit)
+ --disable-apparmor
+ $(use_enable kernel_linux inotify)
+ $(use_enable kernel_FreeBSD kqueue)
+ $(use_enable elogind)
+ $(use_enable systemd)
+ $(use_enable user-session)
+ --disable-embedded-tests
+ --disable-modular-tests
+ $(use_enable debug stats)
+ --with-session-socket-dir="${EPREFIX}"/tmp
+ --with-system-pid-file="${EPREFIX}"/var/run/dbus.pid
+ --with-system-socket="${EPREFIX}"/var/run/dbus/system_bus_socket
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ --with-dbus-user=messagebus
+ $(use_with X x)
+ )
+
+ if [[ ${CHOST} == *-darwin* ]]; then
+ myconf+=(
+ --enable-launchd
+ --with-launchd-agent-dir="${EPREFIX}"/Library/LaunchAgents
+ )
+ fi
+
+ if multilib_is_native_abi; then
+ docconf=(
+ --enable-xml-docs
+ $(use_enable doc doxygen-docs)
+ )
+ else
+ docconf=(
+ --disable-xml-docs
+ --disable-doxygen-docs
+ )
+ myconf+=(
+ --disable-daemon
+ --disable-selinux
+ --disable-libaudit
+ --disable-elogind
+ --disable-systemd
+ --without-x
+ )
+ fi
+
+ einfo "Running configure in ${BUILD_DIR}"
+ ECONF_SOURCE="${S}" econf "${myconf[@]}" "${docconf[@]}"
+
+ if multilib_is_native_abi && use test; then
+ mkdir "${TBD}" || die
+ cd "${TBD}" || die
+ testconf=(
+ $(use_enable test asserts)
+ $(use_enable test checks)
+ $(use_enable test embedded-tests)
+ $(use_enable test stats)
+ $(has_version dev-libs/dbus-glib && echo --enable-modular-tests)
+ )
+ einfo "Running configure in ${TBD}"
+ ECONF_SOURCE="${S}" econf "${myconf[@]}" "${testconf[@]}"
+ fi
+}
+
+multilib_src_compile() {
+ if multilib_is_native_abi; then
+ # after the compile, it uses a selinuxfs interface to
+ # check if the SELinux policy has the right support
+ use selinux && addwrite /selinux/access
+
+ einfo "Running make in ${BUILD_DIR}"
+ emake
+
+ if use test; then
+ einfo "Running make in ${TBD}"
+ emake -C "${TBD}"
+ fi
+ else
+ emake -C dbus libdbus-1.la
+ fi
+}
+
+src_test() {
+ DBUS_VERBOSE=1 virtx emake -j1 -C "${TBD}" check
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi; then
+ emake DESTDIR="${D}" install
+ else
+ emake DESTDIR="${D}" install-pkgconfigDATA
+ emake DESTDIR="${D}" -C dbus \
+ install-libLTLIBRARIES install-dbusincludeHEADERS \
+ install-nodist_dbusarchincludeHEADERS
+ fi
+}
+
+multilib_src_install_all() {
+ newinitd "${FILESDIR}"/dbus.initd-r1 dbus
+
+ if use X; then
+ # dbus X session script (#77504)
+ # turns out to only work for GDM (and startx). has been merged into
+ # other desktop (kdm and such scripts)
+ exeinto /etc/X11/xinit/xinitrc.d
+ doexe "${FILESDIR}"/80-dbus
+ fi
+
+ # needs to exist for dbus sessions to launch
+ keepdir /usr/share/dbus-1/services
+ keepdir /etc/dbus-1/{session,system}.d
+ # machine-id symlink from pkg_postinst()
+ keepdir /var/lib/dbus
+ # let the init script create the /var/run/dbus directory
+ rm -rf "${ED}"/var/run
+
+ dodoc AUTHORS ChangeLog NEWS README doc/TODO
+ readme.gentoo_create_doc
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ # Ensure unique id is generated and put it in /etc wrt #370451 but symlink
+ # for DBUS_MACHINE_UUID_FILE (see tools/dbus-launch.c) and reverse
+ # dependencies with hardcoded paths (although the known ones got fixed already)
+ dbus-uuidgen --ensure="${EROOT}"/etc/machine-id
+ ln -sf "${EPREFIX}"/etc/machine-id "${EROOT}"/var/lib/dbus/machine-id
+
+ if [[ ${CHOST} == *-darwin* ]]; then
+ local plist="org.freedesktop.dbus-session.plist"
+ elog
+ elog
+ elog "For MacOS/Darwin we now ship launchd support for dbus."
+ elog "This enables autolaunch of dbus at session login and makes"
+ elog "dbus usable under MacOS/Darwin."
+ elog
+ elog "The launchd plist file ${plist} has been"
+ elog "installed in ${EPREFIX}/Library/LaunchAgents."
+ elog "For it to be used, you will have to do all of the following:"
+ elog " + cd ~/Library/LaunchAgents"
+ elog " + ln -s ${EPREFIX}/Library/LaunchAgents/${plist}"
+ elog " + logout and log back in"
+ elog
+ elog "If your application needs a proper DBUS_SESSION_BUS_ADDRESS"
+ elog "specified and refused to start otherwise, then export the"
+ elog "the following to your environment:"
+ elog " DBUS_SESSION_BUS_ADDRESS=\"launchd:env=DBUS_LAUNCHD_SESSION_BUS_SOCKET\""
+ fi
+
+ if use user-session; then
+ ewarn "You have enabled user-session. Please note this can cause"
+ ewarn "bogus behaviors in several dbus consumers that are not prepared"
+ ewarn "for this dbus activation method yet."
+ ewarn
+ ewarn "See the following link for background on this change:"
+ ewarn "https://lists.freedesktop.org/archives/systemd-devel/2015-January/027711.html"
+ ewarn
+ ewarn "Known issues are tracked here:"
+ ewarn "https://bugs.gentoo.org/show_bug.cgi?id=576028"
+ fi
+}
diff --git a/sys-apps/dbus/files/dbus-daemon-optional.patch b/sys-apps/dbus/files/dbus-daemon-optional.patch
new file mode 100644
index 000000000000..353dcb5761be
--- /dev/null
+++ b/sys-apps/dbus/files/dbus-daemon-optional.patch
@@ -0,0 +1,75 @@
+From 3c08d28fbae8b0ef3839ef26f8d2a713a9a684f9 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Thu, 21 Feb 2019 23:53:19 +0100
+Subject: [PATCH] Make dbus daemon build optional
+
+---
+ bus/Makefile.am | 2 ++
+ configure.ac | 17 ++++++++++++++++-
+ 2 files changed, 18 insertions(+), 1 deletion(-)
+
+diff --git a/bus/Makefile.am b/bus/Makefile.am
+index 9ae3071..26a770c 100644
+--- a/bus/Makefile.am
++++ b/bus/Makefile.am
+@@ -70,6 +70,7 @@ agentdir=$(LAUNCHD_AGENT_DIR)
+ agent_DATA=org.freedesktop.dbus-session.plist
+ endif
+
++if DBUS_DAEMON
+ if DBUS_BUS_ENABLE_KQUEUE
+ DIR_WATCH_SOURCE=dir-watch-kqueue.c
+ else
+@@ -241,6 +242,7 @@ test_bus_LDADD = \
+ $(top_builddir)/dbus/libdbus-internal.la \
+ $(DBUS_BUS_LIBS) \
+ $(NULL)
++endif DBUS_DAEMON
+
+ install-data-hook:
+ $(mkinstalldirs) $(DESTDIR)$(dbusdatadir)/session.d
+diff --git a/configure.ac b/configure.ac
+index be6b065..854e846 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -202,6 +202,7 @@ AC_ARG_ENABLE([apparmor],
+ [enable_apparmor=$enableval],
+ [enable_apparmor=auto])
+ AC_ARG_ENABLE(libaudit,AS_HELP_STRING([--enable-libaudit],[build audit daemon support for SELinux]),enable_libaudit=$enableval,enable_libaudit=auto)
++AC_ARG_ENABLE(daemon, AS_HELP_STRING([--enable-daemon],[build with the dbus daemon]),enable_daemon=$enableval,enable_daemon=yes)
+ AC_ARG_ENABLE(inotify, AS_HELP_STRING([--enable-inotify],[build with inotify support (linux only)]),enable_inotify=$enableval,enable_inotify=auto)
+ AC_ARG_ENABLE(kqueue, AS_HELP_STRING([--enable-kqueue],[build with kqueue support]),enable_kqueue=$enableval,enable_kqueue=auto)
+ AC_ARG_ENABLE(console-owner-file, AS_HELP_STRING([--enable-console-owner-file],[enable console owner file]),enable_console_owner_file=$enableval,enable_console_owner_file=auto)
+@@ -830,7 +831,20 @@ AC_CHECK_FUNCS(getpeerucred getpeereid)
+
+ AC_CHECK_FUNCS(pipe2 accept4)
+
+-PKG_CHECK_MODULES([EXPAT], [expat])
++# dbusdaemon checks
++if test x$enable_daemon = xno ; then
++ have_daemon=no
++else
++ have_daemon=yes
++fi
++
++dnl check if daemon shall be built
++if test x$have_daemon = xyes; then
++ AC_DEFINE(DBUS_DAEMON,1,[Use daemon])
++ PKG_CHECK_MODULES([EXPAT], [expat])
++fi
++
++AM_CONDITIONAL(DBUS_DAEMON, test x$have_daemon = xyes)
+
+ save_cflags="$CFLAGS"
+ save_libs="$LIBS"
+@@ -1824,6 +1838,7 @@ echo "
+ Building bus stats API: ${enable_stats}
+ Building SELinux support: ${have_selinux}
+ Building AppArmor support: ${have_apparmor}
++ Building daemon: ${have_daemon}
+ Building inotify support: ${have_inotify}
+ Building kqueue support: ${have_kqueue}
+ Building systemd support: ${have_systemd}
+--
+2.20.1
+