summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-12 06:43:24 +0100
committerSam James <sam@gentoo.org>2023-10-12 06:43:24 +0100
commitf5181c566b5e2ad2f796f5e2a8174de6f755f03d (patch)
tree4eb2ecb62fa77ce16717ccad29ca60810ffe1f5e /sys-apps/debianutils
parentsys-apps/kmod: add 31 (diff)
downloadgentoo-f5181c566b5e2ad2f796f5e2a8174de6f755f03d.tar.gz
gentoo-f5181c566b5e2ad2f796f5e2a8174de6f755f03d.tar.bz2
gentoo-f5181c566b5e2ad2f796f5e2a8174de6f755f03d.zip
sys-apps/debianutils: add 5.14
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/debianutils')
-rw-r--r--sys-apps/debianutils/Manifest1
-rw-r--r--sys-apps/debianutils/debianutils-5.14.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/sys-apps/debianutils/Manifest b/sys-apps/debianutils/Manifest
index 7bba354bc8de..2a94ff1c83d9 100644
--- a/sys-apps/debianutils/Manifest
+++ b/sys-apps/debianutils/Manifest
@@ -1,2 +1,3 @@
+DIST debianutils_5.14.tar.xz 79676 BLAKE2B b8e6c5a38cf5fe8e3d8151b1c19cfda4d5866f805453eeb8376a94e1982653cb532ffefdb560f188574ba01e97249b49b69d41f1dda9aa76de4511034736965a SHA512 4a152fec6c363c0ca26339bf8bf3f39ec3c10227bbfe5d2f5974c24a6207fdb6c34644ecfdf0c773d4c778b1a95f91a15697b12b5c0cd9a6d0d8f369373b956f
DIST debianutils_5.7.orig.tar.gz 257231 BLAKE2B 61d2e7abcd359c5dc87b7f91e510e91e1926183c15a572c7d87cf4a590dded2e2ee8c9b4e06f7f478353139870c808927575de233200ad69e084a6f971c4bd24 SHA512 79acd8885abca93842d696167171a359011c49a40f38deeb25bc94d62905f95afa3a7b2540d3bd4b0ffd363c5c48a439a1a68139a29d6c033980b019cea75d92
DIST debianutils_5.8.orig.tar.gz 260865 BLAKE2B 8a2bb3dc06d6e7a41ca53759610c432eaf3797135b13d717d1e8969926388a6955ba020db64a039d1b8dc06a8ee47d5bc960c6f54fe6b9c17e2b361f5636ece3 SHA512 7fddff17804ab334ac1ab3fa4b76a3fed8d83dc2dbf8d9ab1e486b5f226ac8363e98336cfa651c7630eef5fffa4551dbf7a5da1ba60f033b279f9aca624d58a2
diff --git a/sys-apps/debianutils/debianutils-5.14.ebuild b/sys-apps/debianutils/debianutils-5.14.ebuild
new file mode 100644
index 000000000000..f56e99e6a6b0
--- /dev/null
+++ b/sys-apps/debianutils/debianutils-5.14.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="A selection of tools from Debian"
+HOMEPAGE="https://packages.qa.debian.org/d/debianutils.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="BSD GPL-2 SMAIL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x86-linux"
+IUSE="+installkernel static"
+
+PDEPEND="
+ installkernel? (
+ || (
+ sys-kernel/installkernel-gentoo
+ sys-kernel/installkernel-systemd-boot
+ )
+ )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.4.2-no-bs-namespace.patch )
+
+src_prepare() {
+ # Avoid adding po4a dependency, upstream refreshes manpages.
+ sed -i -e '/SUBDIRS/s|po4a||' Makefile.am || die
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ default
+}
+
+src_install() {
+ einstalldocs
+
+ into /
+ dobin run-parts
+
+ into /usr
+ dobin ischroot
+ dosbin savelog
+
+ doman ischroot.1 run-parts.8 savelog.8
+}