summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-10-14 22:48:04 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-10-14 22:48:04 +0200
commitfb3e1aaf3d698ecc2f4130b5ce1862485c877bf7 (patch)
treeb9b7404096aac4a58fd858b15619e3d1b1500e26 /sys-apps/dmidecode
parentdev-lang/spidermonkey: skip typedarray-arg-set-values-same-buffer-other-type.... (diff)
downloadgentoo-fb3e1aaf3d698ecc2f4130b5ce1862485c877bf7.tar.gz
gentoo-fb3e1aaf3d698ecc2f4130b5ce1862485c877bf7.tar.bz2
gentoo-fb3e1aaf3d698ecc2f4130b5ce1862485c877bf7.zip
sys-apps/dmidecode: Bump to version 3.3
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps/dmidecode')
-rw-r--r--sys-apps/dmidecode/Manifest1
-rw-r--r--sys-apps/dmidecode/dmidecode-3.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/dmidecode/Manifest b/sys-apps/dmidecode/Manifest
index 0dbdb951ec60..b7b5f47e54e3 100644
--- a/sys-apps/dmidecode/Manifest
+++ b/sys-apps/dmidecode/Manifest
@@ -1,2 +1,3 @@
DIST dmidecode-3.1.tar.xz 61204 BLAKE2B 439e265dd3f7b225d61b5d4228c0a77b25dd44b5d3672fdd9bbe432f5ae59ac23d2abd80e40621cda934643c9819b05f34d4f5befc8a75b93ae1840caf717cea SHA512 226557ad5747a2a2eb54a938543373b9ddcff032d330ca3b9a066cc81c0e137028f606ffedc042e0220b523346e2f2f7abb0e4b8b34a8bd173719aa858519de9
DIST dmidecode-3.2.tar.xz 54440 BLAKE2B ff5b891b28231bc50657e6fe1fa1345171109ce9baf7fa4558ced482a0616be4206ef69dcf3909611475d543b12691cc2bfe4849d8e3d35b34d1bfffe600af21 SHA512 b080c73fbda756109f0f29935c641e0b32ea9ffe90f0a8254164c9c1ff5617d042347298e6bac31e5463e94fa56efe2b2743238156d878254fc77120e6dc1a18
+DIST dmidecode-3.3.tar.xz 56372 BLAKE2B 7a4557a203702da5d5d6722c72870342e18458b3777d095656e9d5c3a5f80cc712d16b775fa16e4ae9326965a789d393092d45651a449444e268438c1d16773e SHA512 dc77f40a7898011cea1b747d4677be2fbe8f52ec6ac460a5656de2f3389eca83bc416d6494acbe759971b5afce37b78f21ab55c34d62b1105b800e31566d1d22
diff --git a/sys-apps/dmidecode/dmidecode-3.3.ebuild b/sys-apps/dmidecode/dmidecode-3.3.ebuild
new file mode 100644
index 000000000000..8e6e738c4474
--- /dev/null
+++ b/sys-apps/dmidecode/dmidecode-3.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="DMI (Desktop Management Interface) table related utilities"
+HOMEPAGE="https://www.nongnu.org/dmidecode/"
+SRC_URI="https://savannah.nongnu.org/download/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-solaris"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-dmidecode )"
+DEPEND=""
+
+src_prepare() {
+ default
+ sed -i \
+ -e "/^prefix/s:/usr/local:${EPREFIX}/usr:" \
+ -e "/^docdir/s:dmidecode:${PF}:" \
+ -e '/^PROGRAMS !=/d' \
+ Makefile || die
+}
+
+src_compile() {
+ emake \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)"
+}
+
+pkg_postinst() {
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ einfo "dmidecode needs root privileges to read /dev/xsvc"
+ einfo "To make dmidecode useful, either run as root, or chown and setuid the binary."
+ einfo "Note that /usr/sbin/ptrconf and /usr/sbin/ptrdiag give similar"
+ einfo "information without requiring root privileges."
+ fi
+}