summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/dmtcp/dmtcp-1.2.6.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/dmtcp/dmtcp-1.2.6.ebuild')
-rw-r--r--sys-apps/dmtcp/dmtcp-1.2.6.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/sys-apps/dmtcp/dmtcp-1.2.6.ebuild b/sys-apps/dmtcp/dmtcp-1.2.6.ebuild
new file mode 100644
index 000000000000..1ae1ab542fd3
--- /dev/null
+++ b/sys-apps/dmtcp/dmtcp-1.2.6.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit elisp-common eutils multilib
+
+DESCRIPTION="DMTCP is the Distributed MultiThreaded Checkpointing tool"
+HOMEPAGE="http://dmtcp.sourceforge.net/index.html"
+SRC_URI="mirror://sourceforge/dmtcp/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug emacs fast mpi trace"
+
+RDEPEND="sys-libs/readline
+ app-arch/gzip
+ sys-kernel/linux-headers
+ emacs? ( dev-lisp/clisp )
+ mpi? ( virtual/mpi )
+ || ( app-shells/dash
+ app-shells/zsh
+ app-shells/tcsh
+ )"
+
+DEPEND="${RDEPEND}
+ sys-devel/patch"
+
+src_configure() {
+ local myconf="--disable-stale-socket-handling"
+
+ if use debug; then
+ use trace && myconf=" ${myconf} --enable-ptrace-support"
+ myconf=" ${myconf} --disable-pid-virtualization"
+ fi
+
+ use fast && myconf=" ${myconf} --disable-pid-virtualization \
+ --enable-forked-checkpointing \
+ --enable-allocator"
+
+ use mpi && myconf=" ${myconf} --with-mpich=/usr/bin"
+
+ econf $(use_enable debug) $myconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc TODO QUICK-START ${PN}/README
+
+ dodir /usr/share/${PF}/examples
+ mv "${D}"usr/$(get_libdir)/${PN}/examples "${D}"usr/share/${PF}/examples
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}