summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/ed
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/ed')
-rw-r--r--sys-apps/ed/Manifest3
-rw-r--r--sys-apps/ed/ed-1.10.ebuild30
-rw-r--r--sys-apps/ed/ed-1.11.ebuild31
-rw-r--r--sys-apps/ed/ed-1.12.ebuild31
-rw-r--r--sys-apps/ed/files/ed-1.5-build.patch32
-rw-r--r--sys-apps/ed/metadata.xml5
6 files changed, 132 insertions, 0 deletions
diff --git a/sys-apps/ed/Manifest b/sys-apps/ed/Manifest
new file mode 100644
index 000000000000..098f79c08eac
--- /dev/null
+++ b/sys-apps/ed/Manifest
@@ -0,0 +1,3 @@
+DIST ed-1.10.tar.lz 63717 SHA256 9540092c12309b2f4a294fdb8f5bd25f1ad5906a627518486e7733576a637e9a SHA512 b9c59de852609930d2a872f3d9af9ac12be8e80f3d2af49e3626cd909ba46ed4a4260844c636562cd479c5529a116055705260327f61304d8eaf88db6a60059a WHIRLPOOL 7130abba638202e06e078b9e60c9f83e6216fc0cd73891df08eda4a06044b9783a8f974b70dfb8452bdbc7c090bea3776c45b743e7a05bf9988197b51de729d8
+DIST ed-1.11.tar.gz 88303 SHA256 141dba3311e6295898d1b64e86263e40b8e85e3ab4ee4954859a3d3017511041 SHA512 09d86be3442a2e7eba0d1a008752a988324d3fa3e7870c3fffb00cb96f3433b3af3506105a1a6bc97a66754d994f6613c7a233417a4ddc32129adab055ad46b0 WHIRLPOOL 79fcb5436d0bcf9899a9af2abe3911000af136ff28e296ad9c26bf9717bf31f97a843700093baf598f4b5ed892f4a4cdfd2179381fcc4ecd53a55094877f7344
+DIST ed-1.12.tar.gz 87974 SHA256 f2c126d6ec1e5ccfccba05c749d6adf45e84011523ff0c31f595ad41ba892c84 SHA512 546a60e53b45c6416e91239a672e97ee9ce499e4c6d998e278a3870364da0b312e9d3fe681b1c11783d1f3342449502f3ac4d9eb3172c5e7c3b202d82fcb5989 WHIRLPOOL 6d94863786a06f508285ff7e4ca1dbf581a70a109359c101efefe22f070cb3bab46b16bea6110ed9d3894ccdab815ba8b3ff1119ccfe0cf6ea3257e1d27f0980
diff --git a/sys-apps/ed/ed-1.10.ebuild b/sys-apps/ed/ed-1.10.ebuild
new file mode 100644
index 000000000000..241de6ff4df7
--- /dev/null
+++ b/sys-apps/ed/ed-1.10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs unpacker
+
+DESCRIPTION="Your basic line editor"
+HOMEPAGE="http://www.gnu.org/software/ed/"
+SRC_URI="mirror://gnu/ed/${P}.tar.lz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="$(unpacker_src_uri_depends)
+ sys-apps/texinfo"
+RDEPEND=""
+
+src_configure() {
+ # Upstream configure script is moronic.
+ econf \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${CFLAGS} ${LDFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" \
+ --bindir="${EPREFIX}/bin"
+}
diff --git a/sys-apps/ed/ed-1.11.ebuild b/sys-apps/ed/ed-1.11.ebuild
new file mode 100644
index 000000000000..206311ba7d47
--- /dev/null
+++ b/sys-apps/ed/ed-1.11.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Your basic line editor"
+HOMEPAGE="http://www.gnu.org/software/ed/"
+#SRC_URI="mirror://gnu/ed/${P}.tar.lz"
+# Using gzip instead -- the filesize diff is small and lzip uncommon #545344
+SRC_URI="http://fossies.org/linux/privat/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="sys-apps/texinfo"
+RDEPEND=""
+
+src_configure() {
+ # Upstream configure script is moronic.
+ econf \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${CFLAGS} ${LDFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" \
+ --bindir="${EPREFIX}/bin"
+}
diff --git a/sys-apps/ed/ed-1.12.ebuild b/sys-apps/ed/ed-1.12.ebuild
new file mode 100644
index 000000000000..206311ba7d47
--- /dev/null
+++ b/sys-apps/ed/ed-1.12.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Your basic line editor"
+HOMEPAGE="http://www.gnu.org/software/ed/"
+#SRC_URI="mirror://gnu/ed/${P}.tar.lz"
+# Using gzip instead -- the filesize diff is small and lzip uncommon #545344
+SRC_URI="http://fossies.org/linux/privat/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="sys-apps/texinfo"
+RDEPEND=""
+
+src_configure() {
+ # Upstream configure script is moronic.
+ econf \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${CFLAGS} ${LDFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" \
+ --bindir="${EPREFIX}/bin"
+}
diff --git a/sys-apps/ed/files/ed-1.5-build.patch b/sys-apps/ed/files/ed-1.5-build.patch
new file mode 100644
index 000000000000..83ee9c20cfb6
--- /dev/null
+++ b/sys-apps/ed/files/ed-1.5-build.patch
@@ -0,0 +1,32 @@
+http://lists.gnu.org/archive/html/bug-ed/2008-12/msg00001.html
+
+2007-04-16 Mike Frysinger <vapier@gentoo.org>
+
+ * Do not set CC/CXX/CPPFLAGS/LDFLAGS to "" so that user can
+ override if they so choose.
+ * Only set CFLAGS/CXXFLAGS if user did not specify any.
+
+--- ed-1.0/configure
++++ ed-1.0/configure
+@@ -26,10 +26,6 @@
+ mandir='$(datadir)/man'
+ sysconfdir='$(prefix)/etc'
+ program_prefix=
+-CC=
+-CPPFLAGS=
+-CFLAGS='-Wall -W -O2'
+-LDFLAGS=
+
+ # Loop over all args
+ while [ -n "$1" ] ; do
+@@ -105,6 +101,10 @@
+ esac
+ done
+
++# Defaults if the user did not select any
++if [ x"${CFLAGS+set}" != xset ] ; then
++ CFLAGS='-Wall -W -O2'
++fi
+ # Find the source files, if location was not specified.
+ srcdirtext=
+ if [ -z "${srcdir}" ] ; then
diff --git a/sys-apps/ed/metadata.xml b/sys-apps/ed/metadata.xml
new file mode 100644
index 000000000000..96a2d586367d
--- /dev/null
+++ b/sys-apps/ed/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+</pkgmetadata>