summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Ferrazzi <alicef@gentoo.org>2017-09-07 19:04:24 +0900
committerGöktürk Yüksek <gokturk@gentoo.org>2017-10-23 20:10:04 -0400
commit96c76d83f0c369ee8faf3927ff861a13bc353a87 (patch)
tree076760314384e9f8a8ae6f0d6843a93069b3fff3 /sys-apps/elivepatch-server
parentsys-kernel/kpatch: add live ebuild (diff)
downloadgentoo-96c76d83f0c369ee8faf3927ff861a13bc353a87.tar.gz
gentoo-96c76d83f0c369ee8faf3927ff861a13bc353a87.tar.bz2
gentoo-96c76d83f0c369ee8faf3927ff861a13bc353a87.zip
sys-apps/elivepatch-server: add live ebuild
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'sys-apps/elivepatch-server')
-rw-r--r--sys-apps/elivepatch-server/elivepatch-server-9999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/elivepatch-server/elivepatch-server-9999.ebuild b/sys-apps/elivepatch-server/elivepatch-server-9999.ebuild
new file mode 100644
index 000000000000..572a789c43c0
--- /dev/null
+++ b/sys-apps/elivepatch-server/elivepatch-server-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Live patch building server with RESTFul Api for elivepatch-client"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Elivepatch"
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/aliceinwire/elivepatch-server.git"
+else
+ SRC_URI="https://github.com/aliceinwire/elivepatch-server/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+RDEPEND="
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-restful[${PYTHON_USEDEP}]
+ =sys-kernel/kpatch-9999"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ newinitd init/elivepatch.init ${PN}
+ newconfd init/elivepatch.confd ${PN}
+ distutils-r1_python_install_all
+}