summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-05-03 09:50:16 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-05-03 09:52:43 +0200
commitbc234389603637e08add7986db85d196b9158c80 (patch)
tree449b25ac176c427f0e9d7a93c47c527888ad9906 /sys-apps/ethtool
parentdev-db/mariadb: remove libressl support (diff)
downloadgentoo-bc234389603637e08add7986db85d196b9158c80.tar.gz
gentoo-bc234389603637e08add7986db85d196b9158c80.tar.bz2
gentoo-bc234389603637e08add7986db85d196b9158c80.zip
sys-apps/ethtool: Bump to version 5.12
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps/ethtool')
-rw-r--r--sys-apps/ethtool/Manifest1
-rw-r--r--sys-apps/ethtool/ethtool-5.12.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/sys-apps/ethtool/Manifest b/sys-apps/ethtool/Manifest
index fe3a172837e5..87e58ed323a8 100644
--- a/sys-apps/ethtool/Manifest
+++ b/sys-apps/ethtool/Manifest
@@ -1,4 +1,5 @@
DIST ethtool-5.10.tar.xz 310536 BLAKE2B acc91ff2f7cf233a5a7bc85e32fbcf78e3923b240ab3e3300fa11d42769b664b1b5740ad6577daf4ef1b1054432e2323429ee63774af5e0210c1ec1c7d6aa4ac SHA512 128ecc0445ec44e231d95158a71cea2c03f059314f1a844cfb2f424970bd68608fb73b8dc5e8905b88ad0da2b65a8884a626be78d6d25f770ce043c6c87580a6
+DIST ethtool-5.12.tar.xz 311004 BLAKE2B 640d4a1576afea60c673a6060b649d10ccb2d2be64a817e4d74daeb6de4da2d30ccb059ff1113e05f9c44898f08beefd706be2ea6e323c42032c4d93926d380a SHA512 9825f0bf10851f0bd9c3e621785144a5ed5f3fbedacb1801aa6a9b4685c870fa9bfac8eb552c900d20be06240c017dd001fde6be7aecc8c466bbe9ade8b1d002
DIST ethtool-5.4.tar.xz 239288 BLAKE2B 8c8b2bee53fe3e71510684ca7c6f64153cb6f1c5ebe44cd4d1dc351885d2d9957eb206a96bda9efadb5faa0e15a3f0ba07923d7e29b27694e3e3f605151a940d SHA512 c7bfe7eae2ba207d710716274e9f5ae275c57d0bebc0a9acb95677125e64f1b42ef610032011fb59894aab46973988bad40fddbc5ccc238893e7da66f913255b
DIST ethtool-5.8.tar.xz 299416 BLAKE2B ea7433205eba831b6ba56e140c73cfe283cc5dc56ced963414a017b0d6b6fbde9d0195ff64ebdc060351e5e9844af8beb8f00f7e04d76b04f958b166cda7e589 SHA512 5eada909f82573ad93bc5476e6f8d50f68ce2c9948558877eb6ace8dc17aee895b2f27343592f5f23eaef0e0fc70b5f776f76e75d9614bab305a2819ca82370e
DIST ethtool-5.9.tar.xz 307792 BLAKE2B 0cb5b56f6367bba18c92b1d420471be0b203e05d36fec1495f18de7a2e793fb12cd57b3f2f79369327be1b76a9ec749a65b91801c90da79de9d23da62e628fcb SHA512 9166a06b823373188e754b3085cf8e8f71455d83d1bcfcaf1350433b21bdbc6ae851f62108d3d2e3bbbca33ca595382cd2c68966ce4824b55f7f59eb0996bf36
diff --git a/sys-apps/ethtool/ethtool-5.12.ebuild b/sys-apps/ethtool/ethtool-5.12.ebuild
new file mode 100644
index 000000000000..b9870d909410
--- /dev/null
+++ b/sys-apps/ethtool/ethtool-5.12.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Utility for examining and tuning ethernet-based network interfaces"
+HOMEPAGE="https://www.kernel.org/pub/software/network/ethtool/"
+SRC_URI="https://www.kernel.org/pub/software/network/ethtool/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+netlink"
+
+BDEPEND="app-arch/xz-utils"
+RDEPEND="netlink? ( net-libs/libmnl )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf $(use_enable netlink)
+}