summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-07-06 02:29:39 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-07-06 02:29:39 +0200
commit1c1d7369da1551b8ea50e9ad5978e82e76210c6e (patch)
tree9e48b9a183a233594a70d1ca827b390575901bd3 /sys-apps/fakeroot/fakeroot-1.23.ebuild
parentapp-admin/ansible: 2.4.6.0 and 2.6.1 bup (diff)
downloadgentoo-1c1d7369da1551b8ea50e9ad5978e82e76210c6e.tar.gz
gentoo-1c1d7369da1551b8ea50e9ad5978e82e76210c6e.tar.bz2
gentoo-1c1d7369da1551b8ea50e9ad5978e82e76210c6e.zip
sys-apps/fakeroot: bump to v1.23
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sys-apps/fakeroot/fakeroot-1.23.ebuild')
-rw-r--r--sys-apps/fakeroot/fakeroot-1.23.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/fakeroot/fakeroot-1.23.ebuild b/sys-apps/fakeroot/fakeroot-1.23.ebuild
new file mode 100644
index 000000000000..91ad0aff45d0
--- /dev/null
+++ b/sys-apps/fakeroot/fakeroot-1.23.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="A fake root environment by means of LD_PRELOAD and SysV IPC (or TCP) trickery"
+HOMEPAGE="https://packages.qa.debian.org/f/fakeroot.html"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${P/-/_}.orig.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="acl debug static-libs test"
+
+DEPEND="
+ sys-libs/libcap
+ acl? ( sys-apps/acl )
+ test? ( app-arch/sharutils )"
+
+DOCS="AUTHORS BUGS DEBUG README doc/README.saving"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.19-no-acl_h.patch
+ "${FILESDIR}"/${PN}-1.20.2-glibc-2.24.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ export ac_cv_header_sys_acl_h=$(usex acl)
+
+ use debug && append-cppflags "-DLIBFAKEROOT_DEBUGGING"
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -o -name '*.a' -delete || die
+}