summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/fwcrv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/fwcrv')
-rw-r--r--sys-apps/fwcrv/Manifest1
-rw-r--r--sys-apps/fwcrv/files/fwcrv-0.1.0-endian.patch47
-rw-r--r--sys-apps/fwcrv/fwcrv-0.1.0.ebuild30
-rw-r--r--sys-apps/fwcrv/metadata.xml5
4 files changed, 83 insertions, 0 deletions
diff --git a/sys-apps/fwcrv/Manifest b/sys-apps/fwcrv/Manifest
new file mode 100644
index 000000000000..321f392cf7bc
--- /dev/null
+++ b/sys-apps/fwcrv/Manifest
@@ -0,0 +1 @@
+DIST fwcrv-0.1.0.tar.gz 76154 RMD160 df46067779b5440ba99da6120a89b8ef0f21f4cb SHA1 8c48a332acbe4def9816549f2c8f47255fb81d8f SHA256 f6585c20149c95a7ea7d3cef8ccf30fe2211ca3d892ce0b265ada4163b351a36
diff --git a/sys-apps/fwcrv/files/fwcrv-0.1.0-endian.patch b/sys-apps/fwcrv/files/fwcrv-0.1.0-endian.patch
new file mode 100644
index 000000000000..565a15736d9b
--- /dev/null
+++ b/sys-apps/fwcrv/files/fwcrv-0.1.0-endian.patch
@@ -0,0 +1,47 @@
+diff -ruN src/functions.c /tmp/src/functions.c
+--- src/functions.c 2002-11-14 23:46:11.000000000 +0100
++++ src.new/functions.c 2006-03-22 11:51:03.000000000 +0100
+@@ -59,7 +59,7 @@
+ byte ParseCommandLineOptions( int ArgCount, char *ArgValue[], byte *Mode, byte *ReadLength )
+ {
+ int i;
+- char *ArgString;
++ unsigned char *ArgString;
+ byte Node_ID;
+
+ Node_ID = 0; // Default Node_ID used is 0
+diff -ruN src/functions.h /tmp/src/functions.h
+--- src/functions.h 2001-06-21 01:11:43.000000000 +0200
++++ src.new/functions.h 2006-03-22 11:47:48.000000000 +0100
+@@ -16,18 +16,29 @@
+ * byte2 = bits 08-15 (on ix86, bits 16-23)
+ * byte3 = bits 00-07 (on ix86, bits 24-31)
+ * *****************************************************************************************************/
++
++#if __BYTE_ORDER == __BIG_ENDIAN
++
++#define QBYTE3( q ) ( (byte) ( q >> 24 ) )
++#define QBYTE2( q ) ( (byte) ( q >> 16 ) )
++#define QBYTE1( q ) ( (byte) ( q >> 8 ) )
++#define QBYTE0( q ) ( (byte) q )
++
++#else
++
+ #define QBYTE0( q ) ( (byte) ( q >> 24 ) )
+ #define QBYTE1( q ) ( (byte) ( q >> 16 ) )
+ #define QBYTE2( q ) ( (byte) ( q >> 8 ) )
+ #define QBYTE3( q ) ( (byte) q )
+
++#endif
++
+ /* Macro pour inverser les octets a l'interieur d'un quadlet */
+ #define QSWAP( q ) ( ( q << 24 ) & 0xFF000000 ) + \
+ ( ( q << 8 ) & 0x00FF0000 ) + \
+ ( ( q >> 8 ) & 0x0000FF00 ) + \
+ ( ( q >> 24 ) & 0x000000FF )
+
+-
+ /* ******************************************************************************************************
+ * ParseCommandLineOptions
+ * Initialisation of the different options passed as arguments on the command line
+
diff --git a/sys-apps/fwcrv/fwcrv-0.1.0.ebuild b/sys-apps/fwcrv/fwcrv-0.1.0.ebuild
new file mode 100644
index 000000000000..f6dceea1b7b7
--- /dev/null
+++ b/sys-apps/fwcrv/fwcrv-0.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="FireWire CSR Config ROM Viewer"
+HOMEPAGE="http://www.hugovil.com/en/fwcrv/"
+SRC_URI="http://www.hugovil.com/repository/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc"
+IUSE=""
+DEPEND="sys-libs/libraw1394"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-endian.patch
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README src/testdata.txt TODO
+}
diff --git a/sys-apps/fwcrv/metadata.xml b/sys-apps/fwcrv/metadata.xml
new file mode 100644
index 000000000000..96a2d586367d
--- /dev/null
+++ b/sys-apps/fwcrv/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+</pkgmetadata>