summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-12-23 22:33:11 +0100
committerManuel Rüger <mrueg@gentoo.org>2015-12-23 22:33:11 +0100
commit363bd9b1915554ca1edce60dc67932ba64e139ea (patch)
treed0bdc290b67c0c898a75ffb8a3d01b03c2941197 /sys-apps/fwts/fwts-15.12.00.ebuild
parentdev-ruby/spring: Version bump (diff)
downloadgentoo-363bd9b1915554ca1edce60dc67932ba64e139ea.tar.gz
gentoo-363bd9b1915554ca1edce60dc67932ba64e139ea.tar.bz2
gentoo-363bd9b1915554ca1edce60dc67932ba64e139ea.zip
sys-apps/fwts: Version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'sys-apps/fwts/fwts-15.12.00.ebuild')
-rw-r--r--sys-apps/fwts/fwts-15.12.00.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/fwts/fwts-15.12.00.ebuild b/sys-apps/fwts/fwts-15.12.00.ebuild
new file mode 100644
index 000000000000..0c1ca88e0be5
--- /dev/null
+++ b/sys-apps/fwts/fwts-15.12.00.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools
+DESCRIPTION="Firmware Test Suite"
+HOMEPAGE="https://wiki.ubuntu.com/Kernel/Reference/fwts"
+SRC_URI="https://launchpad.net/ubuntu/+archive/primary/+files/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-libs/json-c-0.10-r1
+ dev-libs/glib:2
+ dev-libs/libpcre
+ sys-apps/pciutils
+ sys-power/iasl
+ sys-power/pmtools
+ sys-apps/dmidecode"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+S=${WORKDIR}
+
+src_prepare(){
+ sed -i -e 's/-Wall -Werror/-Wall/' configure.ac {,src/,src/lib/src/}Makefile.am || die
+ sed -i -e 's:/usr/bin/lspci:'$(type -p lspci)':' src/lib/include/fwts_binpaths.h || die
+
+ # Fix json-c includes
+ sed -e 's/^#include <json\//#include <json-c\//g' -i \
+ configure.ac || die
+ sed -e 's/^#include <json.h>/#include <json-c\/json.h>/' \
+ -i src/lib/include/fwts_json.h \
+ src/utilities/kernelscan.c || die
+ sed -e 's/-ljson/-ljson-c/'\
+ -i src/Makefile.am\
+ src/lib/src/Makefile.am\
+ src/utilities/Makefile.am || die
+
+ eautoreconf
+}