summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/fwts
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/fwts')
-rw-r--r--sys-apps/fwts/Manifest2
-rw-r--r--sys-apps/fwts/fwts-14.12.00.ebuild49
-rw-r--r--sys-apps/fwts/fwts-15.03.01.ebuild45
-rw-r--r--sys-apps/fwts/metadata.xml11
4 files changed, 107 insertions, 0 deletions
diff --git a/sys-apps/fwts/Manifest b/sys-apps/fwts/Manifest
new file mode 100644
index 000000000000..692b8dc611f0
--- /dev/null
+++ b/sys-apps/fwts/Manifest
@@ -0,0 +1,2 @@
+DIST fwts-V14.12.00.tar.gz 3089700 SHA256 9fbc6d1bb8cff8c445d4b2ad0c080e7711564a35982e8a946156b7258e82f2ec SHA512 594cfdadcef031216807eccbf7f5a741643ff33322d84994027afdd08923fa423e1dd2621b9093034e7ac99cc2147b9dcb8b6f4dc2662b10232e55a3261aa91e WHIRLPOOL 2be8d45034e4337b6366d8fcd535010412f02d25859f041cb348b693c5e92822c1a0806a37b77ea4815899b7f03d946326caaec64e91d8d09baaba5301cae353
+DIST fwts_15.03.01.orig.tar.gz 3097112 SHA256 9926baa672159e7990abcfd10c003db8dc0db6a45212189e00ae217504c1fa26 SHA512 3f27b21d67dd7db64547c19e2d74fc909aa5d64fc3aedf0fbca403111bb5578c97a0c7f930b540bcb48f48da8a47e4e02bd679170d7b003b40a49f8358be6033 WHIRLPOOL 2a347785105c02611cec7566643b2b8d5d81c555737e4f5a34b3564dafb938a3fa0bb4d575e0da4c216fbd518c44fddcd243dc07bbd5b0a8cd7a4321f0e01b9a
diff --git a/sys-apps/fwts/fwts-14.12.00.ebuild b/sys-apps/fwts/fwts-14.12.00.ebuild
new file mode 100644
index 000000000000..eab1f2a1788e
--- /dev/null
+++ b/sys-apps/fwts/fwts-14.12.00.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools
+DESCRIPTION="Firmware Test Suite"
+HOMEPAGE="https://wiki.ubuntu.com/Kernel/Reference/fwts"
+SRC_URI="http://fwts.ubuntu.com/release/${PN}-V${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/json-c
+ dev-libs/glib:2
+ dev-libs/libpcre
+ sys-apps/pciutils
+ sys-power/iasl
+ sys-power/pmtools
+ sys-apps/dmidecode"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+S=${WORKDIR}
+
+src_prepare(){
+ sed -i -e 's/-Wall -Werror/-Wall/' configure.ac {,src/,src/lib/src/}Makefile.am || die
+ sed -i -e 's:/usr/bin/lspci:'$(type -p lspci)':' src/lib/include/fwts_binpaths.h || die
+
+ # Fix json-c includes
+ if has_version '>=dev-libs/json-c-0.10-r1'; then
+ sed -e 's/^#include <json\//#include <json-c\//g' -i \
+ configure.ac \
+ src/acpi/syntaxcheck/syntaxcheck.c \
+ src/lib/include/fwts_json.h \
+ src/lib/src/fwts_klog.c \
+ src/lib/src/fwts_log_json.c \
+ src/utilities/kernelscan.c || die
+ sed -e 's/-ljson/-ljson-c/'\
+ -i src/Makefile.am\
+ src/lib/src/Makefile.am\
+ src/utilities/Makefile.am || die
+ fi
+
+ eautoreconf
+}
diff --git a/sys-apps/fwts/fwts-15.03.01.ebuild b/sys-apps/fwts/fwts-15.03.01.ebuild
new file mode 100644
index 000000000000..0c1ca88e0be5
--- /dev/null
+++ b/sys-apps/fwts/fwts-15.03.01.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools
+DESCRIPTION="Firmware Test Suite"
+HOMEPAGE="https://wiki.ubuntu.com/Kernel/Reference/fwts"
+SRC_URI="https://launchpad.net/ubuntu/+archive/primary/+files/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-libs/json-c-0.10-r1
+ dev-libs/glib:2
+ dev-libs/libpcre
+ sys-apps/pciutils
+ sys-power/iasl
+ sys-power/pmtools
+ sys-apps/dmidecode"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+S=${WORKDIR}
+
+src_prepare(){
+ sed -i -e 's/-Wall -Werror/-Wall/' configure.ac {,src/,src/lib/src/}Makefile.am || die
+ sed -i -e 's:/usr/bin/lspci:'$(type -p lspci)':' src/lib/include/fwts_binpaths.h || die
+
+ # Fix json-c includes
+ sed -e 's/^#include <json\//#include <json-c\//g' -i \
+ configure.ac || die
+ sed -e 's/^#include <json.h>/#include <json-c\/json.h>/' \
+ -i src/lib/include/fwts_json.h \
+ src/utilities/kernelscan.c || die
+ sed -e 's/-ljson/-ljson-c/'\
+ -i src/Makefile.am\
+ src/lib/src/Makefile.am\
+ src/utilities/Makefile.am || die
+
+ eautoreconf
+}
diff --git a/sys-apps/fwts/metadata.xml b/sys-apps/fwts/metadata.xml
new file mode 100644
index 000000000000..cfeca1024cfd
--- /dev/null
+++ b/sys-apps/fwts/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">ubuntu</remote-id>
+ </upstream>
+</pkgmetadata>