summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-03-05 14:14:30 -0500
committerMike Gilbert <floppym@gentoo.org>2016-03-05 14:15:32 -0500
commitafd1052fd33d0c5352b763ce9ac1a8699e309020 (patch)
tree914c1c9bc456ea536a912fc2375c63faf828305f /sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-5.ebuild
parentsys-apps/gentoo-systemd-integration: Revamp the live ebuild (diff)
downloadgentoo-afd1052fd33d0c5352b763ce9ac1a8699e309020.tar.gz
gentoo-afd1052fd33d0c5352b763ce9ac1a8699e309020.tar.bz2
gentoo-afd1052fd33d0c5352b763ce9ac1a8699e309020.zip
sys-apps/gentoo-systemd-integration: Bump to version 5
Package-Manager: portage-2.2.27_p64
Diffstat (limited to 'sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-5.ebuild')
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-5.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-5.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-5.ebuild
new file mode 100644
index 000000000000..93648ddc5336
--- /dev/null
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-systemd-integration.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+inherit systemd
+
+DESCRIPTION="systemd integration files for Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Systemd"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/systemd-207
+ !sys-fs/eudev
+ !sys-fs/udev"
+
+if [[ ${PV} == 9999 ]]; then
+ DEPEND+=" sys-devel/systemd-m4"
+fi
+
+src_prepare() {
+ default
+ [[ ${PV} != 9999 ]] || eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ # TODO: solve it better in the eclass
+ --with-systemdsystemgeneratordir="$(systemd_get_utildir)"/system-generators
+ )
+
+ econf "${myeconfargs[@]}"
+}