summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/gentoo-systemd-integration
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/gentoo-systemd-integration')
-rw-r--r--sys-apps/gentoo-systemd-integration/Manifest2
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-2.ebuild28
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-4.ebuild30
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild44
-rw-r--r--sys-apps/gentoo-systemd-integration/metadata.xml11
5 files changed, 115 insertions, 0 deletions
diff --git a/sys-apps/gentoo-systemd-integration/Manifest b/sys-apps/gentoo-systemd-integration/Manifest
new file mode 100644
index 000000000000..5e59ca78471d
--- /dev/null
+++ b/sys-apps/gentoo-systemd-integration/Manifest
@@ -0,0 +1,2 @@
+DIST gentoo-systemd-integration-2.tar.bz2 51951 SHA256 2466a11d9b6f6e8d726cb5549bc1c38d28d6742d596e2b2c455c9089c1baf7fd SHA512 dc962165516612ca0ff41fdbd53a420549967a3952640ae7d37aafdbb3543a9b37a928e0528fcbbce74e0ded970e311c350272856fc8a75d9c8dc94a960e3bbc WHIRLPOOL 0517b515b9d01605c46d95fc3e86bf38c200923e3b7df1dde59b875c3eeef232c7dec38833007a943390631cb8eeb4f7c89e79c4b8dab737eea8c63bb36341bf
+DIST gentoo-systemd-integration-4.tar.bz2 52449 SHA256 7027bd2056449e5ec8f9fc3da81c0f157810d482bfa11be48903643335fc6bde SHA512 2f60a98062fc5b9c7247e5df77b8875e532d28b2b903a2770713bbcfb2706f0f1bd7809396dd49ff1cc41f69d8c3dceaef87909fa8683c458a5f818f5e05a574 WHIRLPOOL f87b8aa01f24fad4ff90e694fa03b718425bbb0c0dc8a00950b0ae81230f3b92255d07efc9161707a35c8f3e0e7664c57b7ae061ccc0d896bfc55a632a8b4f09
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-2.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-2.ebuild
new file mode 100644
index 000000000000..4f63e11be5db
--- /dev/null
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils systemd
+
+DESCRIPTION="systemd integration files for Gentoo"
+HOMEPAGE="https://bitbucket.org/mgorny/gentoo-systemd-integration"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND=">=sys-apps/systemd-207"
+
+src_configure() {
+ local myeconfargs=(
+ "$(systemd_with_unitdir)"
+ # TODO: solve it better in the eclass
+ --with-systemdsystemgeneratordir="$(systemd_get_utildir)"/system-generators
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-4.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-4.ebuild
new file mode 100644
index 000000000000..af14c6a96ad3
--- /dev/null
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils systemd
+
+DESCRIPTION="systemd integration files for Gentoo"
+HOMEPAGE="https://bitbucket.org/mgorny/gentoo-systemd-integration"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND=">=sys-apps/systemd-207
+ !sys-fs/eudev
+ !sys-fs/udev"
+
+src_configure() {
+ local myeconfargs=(
+ "$(systemd_with_unitdir)"
+ # TODO: solve it better in the eclass
+ --with-systemdsystemgeneratordir="$(systemd_get_utildir)"/system-generators
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild
new file mode 100644
index 000000000000..7adc033f3c92
--- /dev/null
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=1
+EGIT_REPO_URI="http://bitbucket.org/mgorny/${PN}.git"
+inherit git-2
+#endif
+
+inherit autotools-utils systemd
+
+DESCRIPTION="systemd integration files for Gentoo"
+HOMEPAGE="https://bitbucket.org/mgorny/gentoo-systemd-integration"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=sys-apps/systemd-207
+ !sys-fs/eudev
+ !sys-fs/udev"
+
+#if LIVE
+SRC_URI=
+KEYWORDS=
+
+DEPEND="${DEPEND}
+ sys-devel/systemd-m4"
+#endif
+
+src_configure() {
+ local myeconfargs=(
+ "$(systemd_with_unitdir)"
+ # TODO: solve it better in the eclass
+ --with-systemdsystemgeneratordir="$(systemd_get_utildir)"/system-generators
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/sys-apps/gentoo-systemd-integration/metadata.xml b/sys-apps/gentoo-systemd-integration/metadata.xml
new file mode 100644
index 000000000000..c46ecee5b0be
--- /dev/null
+++ b/sys-apps/gentoo-systemd-integration/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>systemd@gentoo.org</email>
+ <name>Gentoo systemd team</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="bitbucket">mgorny/gentoo-systemd-integration</remote-id>
+ </upstream>
+</pkgmetadata>