summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/gsmartcontrol
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/gsmartcontrol')
-rw-r--r--sys-apps/gsmartcontrol/Manifest1
-rw-r--r--sys-apps/gsmartcontrol/gsmartcontrol-0.8.7.ebuild41
-rw-r--r--sys-apps/gsmartcontrol/metadata.xml12
3 files changed, 54 insertions, 0 deletions
diff --git a/sys-apps/gsmartcontrol/Manifest b/sys-apps/gsmartcontrol/Manifest
new file mode 100644
index 000000000000..85a7c9d95bb1
--- /dev/null
+++ b/sys-apps/gsmartcontrol/Manifest
@@ -0,0 +1 @@
+DIST gsmartcontrol-0.8.7.tar.bz2 684394 SHA256 708fa803243abb852ed52050fc82cd3592a798c02743342441996e77f19ffec6 SHA512 3258ddcb448460afeef8d617ab5bb4720c9b2444452bc45d6798ec645da4862236fbb3fe0116a1cc904f5353481df87603bd2b6d808f348c250bde3624c8403a WHIRLPOOL 24fb546c7175306c8cdd8906b506471d20668de0cd078a8205ec87eff50ce0eb52dc04b3b05e771f8789ef852e5f97675c7c224ab6450d90a3e2ac3e51578d2a
diff --git a/sys-apps/gsmartcontrol/gsmartcontrol-0.8.7.ebuild b/sys-apps/gsmartcontrol/gsmartcontrol-0.8.7.ebuild
new file mode 100644
index 000000000000..053a68bd3fed
--- /dev/null
+++ b/sys-apps/gsmartcontrol/gsmartcontrol-0.8.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit gnome2-utils
+
+DESCRIPTION="Hard disk drive health inspection tool"
+HOMEPAGE="http://gsmartcontrol.sourceforge.net/home/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2 GPL-3 ) Boost-1.0 BSD Unlicense ZLIB"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+COMMON_DEPEND="dev-cpp/gtkmm:2.4
+ dev-libs/libpcre
+ sys-apps/smartmontools"
+RDEPEND="${COMMON_DEPEND}
+ x11-apps/xmessage"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ test? ( dev-util/gtk-builder-convert )"
+
+DOCS="TODO" # See 'dist_doc_DATA' value in Makefile.am
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use test tests)
+}
+
+src_install() {
+ default
+ rm -f "${ED}"/usr/share/doc/${PF}/LICENSE_* || die
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }
diff --git a/sys-apps/gsmartcontrol/metadata.xml b/sys-apps/gsmartcontrol/metadata.xml
new file mode 100644
index 000000000000..77c4c35f6b24
--- /dev/null
+++ b/sys-apps/gsmartcontrol/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>base-system</herd>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">gsmartcontrol</remote-id>
+ </upstream>
+</pkgmetadata>